summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--dkms.conf7
3 files changed, 50 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a3a39a3e142..7fd4a033b715 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = looking-glass-git
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
- pkgver = a10.r31.g859e984
+ pkgver = a10.r67.gf63c804
pkgrel = 1
url = https://looking-glass.hostfission.com
arch = x86_64
@@ -9,17 +9,24 @@ pkgbase = looking-glass-git
makedepends = sdl2_ttf
makedepends = spice-protocol
makedepends = libconfig
- makedepends = libva
+ source = looking-glass::git+https://github.com/gnif/LookingGlass.git
+ source = dkms.conf
+ sha512sums = SKIP
+ sha512sums = e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8
+
+pkgname = looking-glass-git
+ pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
depends = sdl2_ttf
depends = glu
depends = openssl
depends = fontconfig
depends = libconfig
- depends = libva
provides = looking-glass
conflicts = looking-glass
- source = looking-glass::git+https://github.com/gnif/LookingGlass.git
- sha512sums = SKIP
-pkgname = looking-glass-git
+pkgname = looking-glass-module-dkms-git
+ pkgdesc = A kernel module that implements a basic interface to the IVSHMEM device for when using LookingGlass in VM->VM mode
+ depends = dkms
+ provides = looking-glass-module-dkms
+ conflicts = looking-glass-module-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 763747446264..84f91c409ebe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Omar Pakker <archlinux@opakker.nl>
_pkgname=looking-glass
-pkgname="${_pkgname}-git"
-pkgver=a10.r31.g859e984
+pkgbase="${_pkgname}-git"
+pkgname=("${_pkgname}-git" "${_pkgname}-module-dkms-git")
+pkgver=a10.r67.gf63c804
pkgrel=1
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
-makedepends=('git' 'sdl2_ttf' 'spice-protocol' 'libconfig' 'libva')
-depends=('sdl2_ttf' 'glu' 'openssl' 'fontconfig' 'libconfig' 'libva')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git")
-sha512sums=('SKIP')
+makedepends=('git' 'sdl2_ttf' 'spice-protocol' 'libconfig')
+source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
+ "dkms.conf")
+sha512sums=('SKIP'
+ 'e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8')
pkgver() {
cd "${_pkgname}"
@@ -25,6 +25,27 @@ build() {
make
}
-package() {
+package_looking-glass-git() {
+ pkgdesc="A client application for accessing the LookingGlass IVSHMEM device of a VM"
+ depends=('sdl2_ttf' 'glu' 'openssl' 'fontconfig' 'libconfig')
+ provides=("${_pkgname}")
+ conflicts=("${_pkgname}")
+
install -Dm755 "${srcdir}/${_pkgname}/client/bin/looking-glass-client" "${pkgdir}/usr/bin/looking-glass-client"
}
+
+package_looking-glass-module-dkms-git() {
+ pkgdesc="A kernel module that implements a basic interface to the IVSHMEM device for when using LookingGlass in VM->VM mode"
+ depends=('dkms')
+ provides=("${_pkgname}-module-dkms")
+ conflicts=("${_pkgname}-module-dkms")
+
+ install -Dm644 "${srcdir}/dkms.conf" "${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf"
+
+ # Set module name and version
+ sed -e "s/@PKGNAME@/${_pkgname}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf"
+
+ cp -r "${srcdir}/${_pkgname}/module/"* "${pkgdir}/usr/src/${_pkgname}-${pkgver}/"
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..a989e6aedc11
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="@PKGNAME@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="make"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="kvmfr"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"
+AUTOINSTALL="yes"