summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD40
3 files changed, 53 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57c8a4535a7c..d8c2656dc1d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
-# Generated by mksrcinfo v8
-# Sat May 11 21:52:08 UTC 2019
pkgbase = losslesscut
pkgdesc = Crossplatform GUI tool for lossless trimming/cutting of video/audio files
- pkgver = 2.2.0
+ pkgver = 3.23.8
pkgrel = 1
url = https://github.com/mifi/lossless-cut
arch = x86_64
license = MIT
- makedepends = asar
- depends = ffmpeg
- depends = gtk2
depends = nss
- depends = gconf
- source_x86_64 = losslesscut_2.2.0.zip::https://github.com/mifi/lossless-cut/releases/download/v2.2.0/LosslessCut-linux-x64.zip
+ depends = ffmpeg
+ depends = gtk3
+ source_x86_64 = losslesscut-3.23.8.tar.bz2::https://github.com/mifi/lossless-cut/releases/download/v3.23.8/LosslessCut-linux.tar.bz2
source_x86_64 = losslesscut.desktop
- md5sums_x86_64 = d2da40d2f7e1cb55611f7585db7acc89
- md5sums_x86_64 = 460a126a50892d91bdc53de7fa3bc182
+ source_x86_64 = LICENSE
+ source_x86_64 = https://raw.githubusercontent.com/mifi/lossless-cut/master/src/icon.svg
+ sha256sums_x86_64 = 56d5cb40c94c17981b1ae280bfcb47bcb0b9118fe39f3f59eaae5876d9b1289e
+ sha256sums_x86_64 = e91017634fe1e3685a6affd8d72c1ec11af4d390c9fc13d503ae67e8c6e4e852
+ sha256sums_x86_64 = 48affed7162fc2e76f1cd47b50355181b869b4025ff04c2a53b03854e329dca0
+ sha256sums_x86_64 = d3d3da3f403ce1b9f846ae2a38a8fe9938fc458024352a9741b59a920eefacf9
pkgname = losslesscut
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..692b5e2fa047
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Mikael Finstad
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 0294059eb314..14ffcfe60759 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
-# Contributor: filthyAUR
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+# shellcheck disable=SC2034,SC2164
pkgname=losslesscut
-pkgver=2.2.0
+pkgver=3.23.8
pkgrel=1
pkgdesc="Crossplatform GUI tool for lossless trimming/cutting of video/audio files"
arch=('x86_64')
url="https://github.com/mifi/lossless-cut"
license=('MIT')
-depends=('ffmpeg' 'gtk2' 'nss' 'gconf')
-makedepends=('asar')
-source_x86_64=(losslesscut_${pkgver}.zip::"https://github.com/mifi/lossless-cut/releases/download/v${pkgver}/LosslessCut-linux-x64.zip" "losslesscut.desktop")
+depends=('nss' 'ffmpeg' 'gtk3')
+source_x86_64=("$pkgname-$pkgver.tar.bz2::https://github.com/mifi/lossless-cut/releases/download/v$pkgver/LosslessCut-linux.tar.bz2"
+ "losslesscut.desktop"
+ "LICENSE"
+ "https://raw.githubusercontent.com/mifi/lossless-cut/master/src/icon.svg")
+sha256sums_x86_64=('56d5cb40c94c17981b1ae280bfcb47bcb0b9118fe39f3f59eaae5876d9b1289e'
+ 'e91017634fe1e3685a6affd8d72c1ec11af4d390c9fc13d503ae67e8c6e4e852'
+ '48affed7162fc2e76f1cd47b50355181b869b4025ff04c2a53b03854e329dca0'
+ 'd3d3da3f403ce1b9f846ae2a38a8fe9938fc458024352a9741b59a920eefacf9')
-package()
-{
- cd "$srcdir"
- mkdir -p $pkgdir/usr/{share/losslesscut,bin}
- cd LosslessCut-linux-x64
- asar ef resources/app.asar icon.svg
- tar -cf - --exclude app.asar.unpacked --exclude icon.svg . | tar -C "$pkgdir/usr/share/losslesscut" -xvf -
- ln -s /usr/share/losslesscut/LosslessCut $pkgdir/usr/bin/losslesscut
+package() {
+ cd "${srcdir:?}"
+ mkdir -p "${pkgdir:?}"/usr/{share/losslesscut,bin}
+ cd LosslessCut-linux
+ tar -cf - . | tar -C "$pkgdir/usr/share/losslesscut" -xvf -
+ ln -s /usr/share/losslesscut/losslesscut "$pkgdir"/usr/bin/losslesscut
install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
- install -Dm644 icon.svg "$pkgdir"/usr/share/pixmaps/$pkgname.svg
- }
-
-md5sums_x86_64=('d2da40d2f7e1cb55611f7585db7acc89' '460a126a50892d91bdc53de7fa3bc182')
+ install -Dm644 ../icon.svg "$pkgdir"/usr/share/pixmaps/$pkgname.svg
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}