summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8731fe2f5d06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lpc21isp
+ pkgdesc = In-circuit programming (ISP) tool for the NXP (Philips) LPC1300 / LPC1700 / LPC2000 series ARM7 / M0 / M3 microcontrollers
+ pkgver = 1.97
+ pkgrel = 1
+ url = http://sourceforge.net/projects/lpc21isp/
+ arch = i686
+ arch = x86_64
+ license = LGPLv3
+ source = http://downloads.sourceforge.net/project/lpc21isp/lpc21isp/1.97/lpc21isp_197.tar.gz
+ md5sums = 0b286859a05a725647ecb1b3fe9ba606
+
+pkgname = lpc21isp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e979c5b35f53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Matias De la Puente <mfpuente.ar@gmail.com>
+# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
+
+pkgname=lpc21isp
+pkgver=1.97
+pkgrel=1
+pkgdesc="In-circuit programming (ISP) tool for the NXP (Philips) LPC1300 / LPC1700 / LPC2000 series ARM7 / M0 / M3 microcontrollers"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/lpc21isp/"
+license=('LGPLv3')
+depends=()
+makedepends=()
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver/./}.tar.gz)
+md5sums=('0b286859a05a725647ecb1b3fe9ba606')
+
+build() {
+ cd "$srcdir/${pkgname}_${pkgver/./}"
+
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}_${pkgver/./}"
+
+ install -d "$pkgdir/usr/bin"
+ install -m755 lpc21isp "$pkgdir/usr/bin"
+}
+
+# vim:set ts=2 sw=2 et: