summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..627004343a65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lrexrepl
+ pkgdesc = Commandline tool: Search and Replace in multiple files using Regular Expressions and Lua
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://luarocks.org/modules/osch/lrexrepl
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = lua
+ depends = lrexlib-pcre
+ depends = lua-filesystem
+ source = https://github.com/osch/lrexrepl/archive/v0.2.0.tar.gz
+ md5sums = 45432d2704627298edd8e8c88238744a
+
+pkgname = lrexrepl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cca326d3119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: osch <oliver@luced.de>
+pkgname=lrexrepl
+pkgver=0.2.0
+pkgrel=1
+rockrel=1
+pkgdesc="Commandline tool: Search and Replace in multiple files using Regular Expressions and Lua"
+arch=('i686' 'x86_64')
+url="https://luarocks.org/modules/osch/$pkgname"
+license=('MIT')
+depends=('lua' 'lrexlib-pcre' 'lua-filesystem')
+source=("https://github.com/osch/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 lrexrepl "$pkgdir/usr/bin/lrexrepl"
+}
+
+md5sums=('45432d2704627298edd8e8c88238744a')