summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95d0d43d4af..a07c21e76b87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = lua-busted
pkgdesc = Elegant Lua unit testing
pkgver = 2.0.0
- pkgrel = 7
+ pkgrel = 8
url = https://olivinelabs.com/busted
- arch = x86_64
- arch = i686
+ arch = any
license = MIT
+ makedepends = lua
+ makedepends = lua52
+ makedepends = lua51
makedepends = luarocks
source = busted-2.0.0.tar.gz::https://github.com/Olivine-Labs/busted/archive/v2.0.0.tar.gz
sha256sums = fda34db8cd10142d2a88d6df638a7d0874c295fd2bd6338c745cc546dc5847df
diff --git a/PKGBUILD b/PKGBUILD
index 391085d4e7c2..a90202c21245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,20 @@ pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.0.0
_rockrel=1
__rockrel=0
-pkgrel=7
+pkgrel=8
pkgdesc='Elegant Lua unit testing'
-arch=('x86_64' 'i686')
+arch=('any')
url="https://olivinelabs.com/$_rockname"
license=('MIT')
_lua_deps=('cliargs' 'dkjson' 'filesystem' 'luassert' 'mediator' 'penlight' 'say' 'system' 'term')
-makedepends=('luarocks')
+makedepends=('lua' 'lua52' 'lua51' 'luarocks')
source=("${_rockname}-${pkgver}.tar.gz::https://github.com/Olivine-Labs/$_rockname/archive/v$pkgver.tar.gz")
sha256sums=('fda34db8cd10142d2a88d6df638a7d0874c295fd2bd6338c745cc546dc5847df')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version=$1 --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "rockspecs/$_rockname-$pkgver-$__rockrel.rockspec"
+ luarocks --lua-version=$1 --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "rockspecs/$_rockname-$pkgver-$__rockrel.rockspec"
find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
}