summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c64ead752f8..5aeb6f711cd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = lua-cqueues
- pkgver = 20161215
+ pkgver = 20171014
pkgrel = 0
url = http://25thandclement.com/~william/projects/cqueues.html
arch = i686
@@ -9,8 +9,8 @@ pkgbase = lua-cqueues
makedepends = lua51
makedepends = lua52
depends = openssl
- source = https://github.com/wahern/cqueues/archive/rel-20161215.tar.gz
- md5sums = 3e5bfb9ccb7fa8eea4f5d367dd0fe10a
+ source = https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz
+ md5sums = d3912ad77724b223e24d1ba55e9a9293
pkgname = lua-cqueues
pkgdesc = Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.3
diff --git a/PKGBUILD b/PKGBUILD
index 0c1c7043a654..aea59e10c29d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Daurnimator <quae@daurnimator.com>
pkgname=(lua-cqueues lua51-cqueues lua52-cqueues)
-pkgver=20161215
+pkgver=20171014
pkgrel=0
arch=('i686' 'x86_64')
url='http://25thandclement.com/~william/projects/cqueues.html'
license=('MIT')
makedepends=('lua' 'lua51' 'lua52')
depends=('openssl')
-source=('https://github.com/wahern/cqueues/archive/rel-20161215.tar.gz')
-md5sums=('3e5bfb9ccb7fa8eea4f5d367dd0fe10a')
+source=('https://github.com/wahern/cqueues/archive/rel-20171014.tar.gz')
+md5sums=('d3912ad77724b223e24d1ba55e9a9293')
build() {
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make prefix=/usr
}
package_lua-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.3'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.3
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -26,7 +26,7 @@ package_lua-cqueues() {
package_lua51-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.1'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -34,7 +34,7 @@ package_lua51-cqueues() {
package_lua52-cqueues() {
pkgdesc='Continuation Queues: Embeddable asynchronous networking, threading, and notification framework for Lua 5.2'
- cd cqueues-rel-20161215;
+ cd cqueues-rel-20171014;
make DESTDIR=${pkgdir} prefix=/usr install5.2
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}