summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18148a4df030..0f4ff8e43197 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = lua-dkjson
pkgdesc = David Kolf’s Pure Lua JSON module with UTF-8 support and no external dependencies
pkgver = 2.5
- pkgrel = 2
+ pkgrel = 3
url = http://dkolf.de/src/dkjson-lua.fsl/home
arch = any
license = MIT
+ makedepends = lua
+ makedepends = lua52
+ makedepends = lua51
makedepends = luarocks
source = http://dkolf.de/src/dkjson-lua.fsl/tarball/dkjson-2.5.tar.gz
sha256sums = b469e80daa9f2355c675d9293e831f3f69153e49856c59634db97899121a720d
diff --git a/PKGBUILD b/PKGBUILD
index 618d84dba354..ce3eef6e6fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,20 @@
_rockname=dkjson
pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.5
-pkgrel=2
+pkgrel=3
_rockrel=2
pkgdesc='David Kolf’s Pure Lua JSON module with UTF-8 support and no external dependencies'
arch=('any')
url="http://dkolf.de/src/$_rockname-lua.fsl/home"
license=('MIT')
-makedepends=('luarocks')
+makedepends=('lua' 'lua52' 'lua51' 'luarocks')
source=("http://dkolf.de/src/$_rockname-lua.fsl/tarball/$_rockname-$pkgver.tar.gz")
sha256sums=('b469e80daa9f2355c675d9293e831f3f69153e49856c59634db97899121a720d')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
}
package_lua-dkjson() {