summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4f079fcc779..aaa5993e7c3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = lua-penlight-git
- pkgdesc = A set of pure Lua libraries focusing on input data handling, functional programming, and OS path management
- pkgver = 1.5.4.r43.gee381b7
+ pkgdesc = Lua libraries for on input data handling, functional programming, and OS interface
+ pkgver = 1.7.0.r4.ge469fa0
pkgrel = 1
- url = https://github.com/stevedonovan/Penlight
+ url = https://tieske.github.io/Penlight
arch = any
license = MIT
- depends = bash
depends = lua
depends = lua-filesystem
provides = lua-penlight
conflicts = lua-penlight
- source = lua-penlight-git::git+https://github.com/stevedonovan/Penlight.git
+ source = lua-penlight-git::git+https://github.com/Tieske/Penlight.git
md5sums = SKIP
pkgname = lua-penlight-git
diff --git a/PKGBUILD b/PKGBUILD
index f6f67f922a1c..d7abe0dab5cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=lua-penlight-git
-pkgver=1.5.4.r43.gee381b7
+pkgver=1.7.0.r4.ge469fa0
pkgrel=1
-pkgdesc='A set of pure Lua libraries focusing on input data handling, functional programming, and OS path management'
-url='https://github.com/stevedonovan/Penlight'
+pkgdesc='Lua libraries for on input data handling, functional programming, and OS interface'
+url='https://tieske.github.io/Penlight'
arch=('any')
license=('MIT')
conflicts=('lua-penlight')
provides=('lua-penlight')
-depends=('bash' 'lua' 'lua-filesystem')
-source=("${pkgname}::git+https://github.com/stevedonovan/Penlight.git")
+depends=('lua' 'lua-filesystem')
+source=("${pkgname}::git+https://github.com/Tieske/Penlight.git")
md5sums=('SKIP')
pkgver() {
cd ${pkgname}
- # Prefix revision with 'r'; replace all '-' with '.'
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --abbrev=7 HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {