summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fe4ff8bf7e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Jan 26 19:25:25 UTC 2019
+pkgbase = lua-rings
+ pkgdesc = Rings is a library which provides a way to create new Lua states from within Lua.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://keplerproject.github.com/rings
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = rings-1.3.0.tar.gz::https://github.com/keplerproject/rings/archive/v_1_3_0.tar.gz
+ md5sums = f4182f03934d40cbb40d80922febc1b1
+
+pkgname = lua-rings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4fcc4e64658
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=lua-rings
+_rockname=rings
+pkgver=1.3.0
+_tag=${pkgver//./_}
+pkgrel=1
+pkgdesc="Rings is a library which provides a way to create new Lua states from within Lua."
+arch=('i686' 'x86_64')
+url="http://keplerproject.github.com/rings"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("${_rockname}-${pkgver}.tar.gz::https://github.com/keplerproject/${_rockname}/archive/v_${_tag}.tar.gz")
+md5sums=('f4182f03934d40cbb40d80922febc1b1')
+
+build() {
+ cd "$_rockname-v_$_tag"
+ luarocks make --pack-binary-rock --deps-mode=none "rockspecs/$_rockname-$pkgver-1.rockspec"
+}
+
+package() {
+ luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$_rockname-v_$_tag"/*.rock
+ find "$pkgdir/usr" -name manifest -delete
+}