summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ae3c039e6ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = lua-sitegen-git
+ pkgdesc = Static site generator in MoonScript
+ pkgver = r305.3b8eea6
+ pkgrel = 1
+ url = http://leafo.net/sitegen
+ arch = x86_64
+ license = Unknown
+ makedepends = luarocks
+ makedepends = git
+ depends = lua
+ depends = lua-cosmo
+ depends = moonscript
+ depends = lua-socket
+ depends = lua-filesystem
+ depends = lua-cjson
+ depends = lua-date
+ depends = lua-discount
+ depends = lua-ansicolors
+ depends = lua-web_sanitize
+ provides = sitegen
+ source = git+https://github.com/leafo/sitegen
+ sha256sums = SKIP
+
+pkgname = lua-sitegen-git
+ pkgdesc = Sitegen for Lua 5.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1b0e7326c47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=lua-sitegen-git
+pkgver=r305.3b8eea6
+pkgrel=1
+pkgdesc="Static site generator in MoonScript"
+arch=('x86_64')
+url='http://leafo.net/sitegen'
+provides=('sitegen')
+license=('Unknown')
+depends=('lua'
+ 'lua-cosmo'
+ 'moonscript'
+ 'lua-socket'
+ 'lua-filesystem'
+ 'lua-cjson'
+ 'lua-date'
+ 'lua-discount'
+ 'lua-ansicolors'
+ 'lua-web_sanitize')
+makedepends=('luarocks' 'git')
+source=("git+https://github.com/leafo/sitegen")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/sitegen
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p 5.3
+
+ # Build for 5.3
+ (cd 5.3; luarocks build --pack-binary-rock --lua-version=5.3 --deps-mode=none ../sitegen/"sitegen-dev-1.rockspec")
+}
+
+package() {
+ pkgdesc='Sitegen for Lua 5.3'
+
+ luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/*.rock
+
+ # remove luarocks-created root manifest
+ rm "$pkgdir/usr/lib/luarocks/rocks-5.3/manifest"
+} \ No newline at end of file