summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79b403ca5a05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Apr 23 11:27:50 UTC 2016
+pkgbase = lua-utf8
+ pkgdesc = Add UTF-8 support to Lua, compatible with Lua string module.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = http://github.com/starwing/luautf8
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = https://luarocks.org/luautf8-0.1.1-1.src.rock
+ sha256sums = 51aa211a9d39d62c65bfcca4eccb8482a11bfe918992eed58104b646338d62a0
+
+pkgname = lua-utf8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..314566494298
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=lua-utf8
+pkgver=0.1.1
+_rockname=luautf8
+_rockrel=1
+pkgrel=1
+pkgdesc="Add UTF-8 support to Lua, compatible with Lua string module."
+arch=('i686' 'x86_64')
+url="http://github.com/starwing/luautf8"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("https://luarocks.org/${_rockname}-${pkgver}-${_rockrel}.src.rock")
+sha256sums=('51aa211a9d39d62c65bfcca4eccb8482a11bfe918992eed58104b646338d62a0')
+
+package() {
+ luarocks --tree="$pkgdir/usr" install "${_rockname}-${pkgver}-${_rockrel}.src.rock"
+}
+