summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..458d145204ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lua52-jwtjitsi
+ pkgdesc = LUA JWT Jitsi
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/jitsi/luajwtjitsi
+ arch = any
+ license = MIT
+ makedepends = luarocks
+ makedepends = lua52
+ source = git+https://github.com/jitsi/luajwtjitsi#tag=v2.0
+ sha256sums = SKIP
+
+pkgname = lua52-jwtjitsi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..abf374ba10e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+lua52-jwtjitsi*.pkg.tar.zst
+luajwtjitsi/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c89e1a35de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Celogeek <arch-aur-f5d67e@celogeek.com>
+
+pkgname=lua52-jwtjitsi
+pkgver=2.0
+pkgrel=1
+pkgdesc='LUA JWT Jitsi'
+arch=('any')
+url='https://github.com/jitsi/luajwtjitsi'
+license=('MIT')
+makedepends=('luarocks' 'lua52')
+source=("git+https://github.com/jitsi/luajwtjitsi#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "luajwtjitsi"
+ luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none luajwtjitsi*.rockspec
+}
+
+package() {
+ cd "luajwtjitsi"
+ luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+