summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7da1eea551d1..4590f50204b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luacheck-git
pkgdesc = A tool for linting and static analysis of Lua code
- pkgver = latest.r2.g81bb2f2
+ pkgver = 1.0.0.r2.g81bb2f2
pkgrel = 1
url = https://github.com/lunarmodules/luacheck
arch = any
@@ -11,7 +11,7 @@ pkgbase = luacheck-git
depends = lua-filesystem
depends = lua-argparse
optdepends = lua-lanes: for parallel checking
- provides = luacheck=latest.r2.g81bb2f2
+ provides = luacheck=1.0.0.r2.g81bb2f2
conflicts = luacheck
source = git+https://github.com/lunarmodules/luacheck.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 104534bdf046..291d05de6931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=luacheck-git
-pkgver=latest.r2.g81bb2f2
+pkgver=1.0.0.r2.g81bb2f2
pkgrel=1
_rockrel=1
pkgdesc='A tool for linting and static analysis of Lua code'
@@ -24,7 +24,8 @@ sha256sums=('SKIP')
pkgver() {
cd "$_archive"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --match="v*.*.*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {