summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix.test-luksmeta.patch19
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820d89a403e7..f09de18c2ed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luksmeta
pkgdesc = Library for storing metadata in the LUKSv1 header
pkgver = 9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/latchset/luksmeta
arch = x86_64
license = LGPL
@@ -9,8 +9,10 @@ pkgbase = luksmeta
depends = cryptsetup
source = https://github.com/latchset/luksmeta/releases/download/v9/luksmeta-9.tar.bz2
source = Relax-content-tests-in-test-suite.patch
+ source = fix.test-luksmeta.patch
sha512sums = eeecc3de9d621c380d29b2f2ca6ce715f09c20aac8ffc6a3d3cc7dc30c5dc46df686e61928d0accf7e7281ad9baa6ee59a0cf5b58635a311769d8e08c5cc94bd
sha512sums = 145f6ceb7bad2090067c5e994bb0f89ce6388cc3c5b3e27a48704c3ae33615a81dcf309b54aa0d0004782890f9260560a24f274d442b3a397a352f5bac5b638e
+ sha512sums = 674574292ecc9912d63b90db9ffa7c3f862226424d308a6612d769943edde44086268bdcb7a8f8d26b954b881189090520400d49cb14b454537e9f9ea8c3f560
pkgname = luksmeta
diff --git a/PKGBUILD b/PKGBUILD
index 1f58ff86f009..df3fe2e28158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas at gmx dot de>
pkgname=luksmeta
pkgver=9
-pkgrel=2
+pkgrel=3
pkgdesc='Library for storing metadata in the LUKSv1 header'
arch=('x86_64')
url='https://github.com/latchset/luksmeta'
@@ -9,14 +9,18 @@ license=('LGPL')
depends=('cryptsetup')
makedepends=('asciidoc')
source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
- 'Relax-content-tests-in-test-suite.patch')
+ 'Relax-content-tests-in-test-suite.patch'
+ 'fix.test-luksmeta.patch')
sha512sums=('eeecc3de9d621c380d29b2f2ca6ce715f09c20aac8ffc6a3d3cc7dc30c5dc46df686e61928d0accf7e7281ad9baa6ee59a0cf5b58635a311769d8e08c5cc94bd'
- '145f6ceb7bad2090067c5e994bb0f89ce6388cc3c5b3e27a48704c3ae33615a81dcf309b54aa0d0004782890f9260560a24f274d442b3a397a352f5bac5b638e')
+ '145f6ceb7bad2090067c5e994bb0f89ce6388cc3c5b3e27a48704c3ae33615a81dcf309b54aa0d0004782890f9260560a24f274d442b3a397a352f5bac5b638e'
+ '674574292ecc9912d63b90db9ffa7c3f862226424d308a6612d769943edde44086268bdcb7a8f8d26b954b881189090520400d49cb14b454537e9f9ea8c3f560')
prepare() {
cd "$pkgname-$pkgver"
# https://github.com/latchset/luksmeta/issues/6
patch --strip=1 --input="$srcdir/Relax-content-tests-in-test-suite.patch"
+ # https://github.com/latchset/luksmeta/issues/9
+ patch --strip=1 --input="$srcdir/fix.test-luksmeta.patch"
}
build() {
diff --git a/fix.test-luksmeta.patch b/fix.test-luksmeta.patch
new file mode 100644
index 000000000000..0e16f4868a5a
--- /dev/null
+++ b/fix.test-luksmeta.patch
@@ -0,0 +1,19 @@
+Description: Work around test-luksmeta fail when running as non-root
+Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
+Date: 2019-03-01
+Forwarded: no
+
+ The cryptsetup luksFormat program now fails when running as
+ non-root, see #923513
+
+--- a/test-luksmeta
++++ b/test-luksmeta
+@@ -11,7 +11,7 @@
+ trap 'onexit' EXIT
+
+ truncate -s 4M $tmp
+-echo -n foo | cryptsetup luksFormat $tmp -
++echo -n foo | cryptsetup luksFormat --type luks1 $tmp -
+
+ ! ./luksmeta test -d $tmp
+