summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23451bd29222..5033e472cf70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luminance-git
pkgdesc = Luminance is a Philips Hue client for Linux written in Python and GTK+
- pkgver = 21
- pkgrel = 2
+ pkgver = 0.1.0.r0.g33a274c
+ pkgrel = 1
url = https://github.com/craigcabrey/luminance
arch = any
license = GPL2
@@ -15,8 +15,10 @@ pkgbase = luminance-git
depends = dconf
depends = hicolor-icon-theme
depends = python-phue
+ provides = luminance=$pkgver
+ conflicts = luminance
source = git+https://github.com/craigcabrey/luminance.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = luminance-git
diff --git a/PKGBUILD b/PKGBUILD
index 7592f0dd11b8..692d2a10c55d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
-# Maintainer: David Baum <david.baum@naraesk.eu>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: David Baum <david.baum@naraesk.eu>
+
pkgname=luminance-git
-pkgver=21
-pkgrel=2
+_pkgname=luminance
+pkgver=0.1.0.r0.g33a274c
+pkgrel=1
+epoch=
pkgdesc="Luminance is a Philips Hue client for Linux written in Python and GTK+"
arch=('any')
url="https://github.com/craigcabrey/luminance"
license=('GPL2')
-groups=()
depends=('python' 'dconf' 'hicolor-icon-theme' 'python-phue')
makedepends=('git' 'autoconf' 'python' 'python-requests' 'gtk3' 'pygobject-devel')
-optdepends=()
-provides=()
-conflicts=('')
-replaces=()
-backup=()
-options=()
-install=()
-changelog=()
+provides=('luminance=$pkgver')
+conflicts=('luminance')
source=('git+https://github.com/craigcabrey/luminance.git')
-noextract=()
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd luminance
- git rev-list --count HEAD
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
+
build() {
- cd luminance
+ cd "${srcdir}/${_pkgname}"
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd luminance
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir/" install
}