summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--lush-1.2.1.patch24
-rw-r--r--lush.changelog4
4 files changed, 43 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d4b57d38d9e..8033e45b32e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = lush
pkgdesc = An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications.
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = http://lush.sourceforge.net
arch = x86_64
- arch = i686
license = GPL
optdepends = gsl
optdepends = lapack
@@ -17,4 +16,3 @@ pkgbase = lush
sha256sums = 1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9
pkgname = lush
-
diff --git a/PKGBUILD b/PKGBUILD
index 0a0620c77cf5..16a575aaf5be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Maintainer: Maximilian Stein <theoddbird@posteo.org>
+# Maintainer: Majorana Oedipus <majoranaoedipus@posteo.org>
+# Contributor: Maximilian Stein <theoddbird@posteo.org>
# Contributor: Thomas S Hatch <thatch45@gmail.com>
# Contributor: Hannes Rist <cowider@gmail.com>
# Contributor: ackalker <a.c.kalker@gmail.com>
pkgname=lush
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications."
-arch=('x86_64' 'i686')
+changelog="lush.changelog"
+arch=('x86_64')
url="http://lush.sourceforge.net"
license=('GPL')
+depends=('binutils')
optdepends=('gsl' 'lapack' 'sdl' 'opencv' 'alsa-lib' 'libxft')
options=('!libtool')
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
sha256sums=('1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9')
+prepare() {
+ patch -p1 -i $srcdir/../$pkgname-$pkgver.patch
+}
+
build() {
- cd "$srcdir/$pkgname"
- ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+ cd "$srcdir/$pkgname"
+ ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+ make DESTDIR="$pkgdir"/ world
}
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir"/ install
-} \ No newline at end of file
+}
diff --git a/lush-1.2.1.patch b/lush-1.2.1.patch
new file mode 100644
index 000000000000..8807eea2dcb6
--- /dev/null
+++ b/lush-1.2.1.patch
@@ -0,0 +1,24 @@
+diff --unified --recursive --text src/lush/src/dldbfd.c src-patched/lush/src/dldbfd.c
+--- src/lush/src/dldbfd.c 2006-11-03 00:46:09.000000000 +0800
++++ src-patched/lush/src/dldbfd.c 2024-04-21 00:24:56.565453545 +0800
+@@ -845,7 +845,8 @@
+ /* Cleanup bss section */
+ if (sbss)
+ {
+- bfd_set_section_size(ent->abfd, sbss, scommon);
++ bfd_set_section_size(/* ent->abfd, */sbss, scommon); /* PATCH NOTE:
++ * BFD CHANGED THE SIGNATURE */
+ /* Take no risk with alignment */
+ if (sbss->alignment_power < 4)
+ sbss->alignment_power = 4;
+@@ -2347,7 +2348,9 @@
+ }
+ }
+ /* Update I-cache */
+- update_instruction_cache(p->vma, bfd_section_size(abfd, p));
++ update_instruction_cache(p->vma , bfd_section_size(/* abfd, */p));
++ /* PATCH NOTE:
++ * BFD CHANGED THE SIGNATURE */
+ }
+ /* Mark module as relocated */
+ if (externalp)
diff --git a/lush.changelog b/lush.changelog
new file mode 100644
index 000000000000..54d290dbcdc2
--- /dev/null
+++ b/lush.changelog
@@ -0,0 +1,4 @@
+
+
+lush 1.2.1-3
+Add a patch to fix error when linking against new binutils due to API change