summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD37
2 files changed, 47 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4e2c842fe29..9a89ffdeaa1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.10.beta1.r0.g69e3a6c8
+ pkgver = 0.5.10.beta1.r123.g1b08d2fb
pkgrel = 1
url = https://lutris.net/
arch = any
@@ -8,43 +8,42 @@ pkgbase = lutris-git
checkdepends = appstream-glib
makedepends = git
makedepends = meson
- depends = python-gobject
- depends = python-yaml
- depends = python-evdev
- depends = python-dbus
- depends = gtk3
- depends = glib2
- depends = psmisc
+ depends = dbus-python
depends = cabextract
- depends = unzip
- depends = p7zip
depends = curl
- depends = xorg-xrandr
- depends = python-pillow
- depends = python-requests
- depends = gnome-desktop
- depends = webkit2gtk
+ depends = glib2
+ depends = gtk3
depends = mesa-utils
- depends = python-dbus
+ depends = p7zip
+ depends = psmisc
depends = python-distro
- depends = python-magic
+ depends = python-evdev
+ depends = python-gobject
depends = python-lxml
- optdepends = wine: easiest way to get all the libraries missing from the Lutris runtime
- optdepends = winetricks: use system winetricks
- optdepends = vulkan-icd-loader: Vulkan support
- optdepends = lib32-vulkan-icd-loader: Vulkan support
- optdepends = vkd3d: Vulkan 3D support
- optdepends = lib32-vkd3d: Vulkan 3D support
- optdepends = gvfs: GVFS backend
- optdepends = lib32-glibc: for 32bit games support
+ depends = python-magic
+ depends = python-pillow
+ depends = python-requests
+ depends = python-yaml
+ depends = unzip
+ depends = webkit2gtk
+ depends = xorg-xrandr
optdepends = gamemode: Allows games to request a temporary set of optimisations
+ optdepends = gamescope: Draw the game window isolated from your desktop
+ optdepends = gnome-desktop: Get display and resolution using GnomeDesktop
+ optdepends = gvfs: GVFS backend
+ optdepends = innoextract: Extract Inno Setup installers
optdepends = lib32-gamemode: Allows games to request a temporary set of optimisations
- optdepends = mangohud: Display the games' FPS + other information
+ optdepends = lib32-glibc: for 32bit games support
optdepends = lib32-mangohud: Display the games' FPS + other information
- optdepends = innoextract: Extract Inno Setup installers
- optdepends = xorg-xgamma: Restore gamma on game exit
- optdepends = gamescope: draw the game window isolated from your desktop
+ optdepends = lib32-vkd3d: Vulkan 3D support
+ optdepends = lib32-vulkan-icd-loader: Vulkan support
optdepends = linux-steam-integration: start Steam with LSI
+ optdepends = mangohud: Display the games' FPS + other information
+ optdepends = vkd3d: Vulkan 3D support
+ optdepends = vulkan-icd-loader: Vulkan support
+ optdepends = wine: easiest way to get all the libraries missing from the Lutris runtime
+ optdepends = winetricks: use system winetricks
+ optdepends = xorg-xgamma: Restore gamma on game exit
provides = lutris
conflicts = lutris
source = git+https://github.com/lutris/lutris.git
diff --git a/PKGBUILD b/PKGBUILD
index 37fe70d1e5d1..248c46bcaacb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,36 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.10.beta1.r0.g69e3a6c8
+pkgver=0.5.10.beta1.r123.g1b08d2fb
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
url='https://lutris.net/'
license=('GPL3')
-depends=('python-gobject' 'python-yaml' 'python-evdev' 'python-dbus' 'gtk3'
- 'glib2' 'psmisc' 'cabextract' 'unzip' 'p7zip' 'curl' 'xorg-xrandr'
- 'python-pillow' 'python-requests' 'gnome-desktop' 'webkit2gtk'
- 'mesa-utils' 'python-dbus' 'python-distro' 'python-magic' 'python-lxml')
+depends=('dbus-python' 'cabextract' 'curl' 'glib2' 'gtk3' 'mesa-utils' 'p7zip'
+ 'psmisc' 'python-distro' 'python-evdev' 'python-gobject' 'python-lxml'
+ 'python-magic' 'python-pillow' 'python-requests' 'python-yaml' 'unzip'
+ 'webkit2gtk' 'xorg-xrandr')
makedepends=('git' 'meson')
checkdepends=('appstream-glib')
optdepends=(
- 'wine: easiest way to get all the libraries missing from the Lutris runtime'
- 'winetricks: use system winetricks'
- 'vulkan-icd-loader: Vulkan support'
- 'lib32-vulkan-icd-loader: Vulkan support'
- 'vkd3d: Vulkan 3D support'
- 'lib32-vkd3d: Vulkan 3D support'
- 'gvfs: GVFS backend'
- 'lib32-glibc: for 32bit games support'
'gamemode: Allows games to request a temporary set of optimisations'
+ 'gamescope: Draw the game window isolated from your desktop'
+ 'gnome-desktop: Get display and resolution using GnomeDesktop'
+ 'gvfs: GVFS backend'
+ 'innoextract: Extract Inno Setup installers'
'lib32-gamemode: Allows games to request a temporary set of optimisations'
- "mangohud: Display the games' FPS + other information"
+ 'lib32-glibc: for 32bit games support'
"lib32-mangohud: Display the games' FPS + other information"
- 'innoextract: Extract Inno Setup installers'
- 'xorg-xgamma: Restore gamma on game exit'
- 'gamescope: draw the game window isolated from your desktop'
- 'linux-steam-integration: start Steam with LSI')
+ 'lib32-vkd3d: Vulkan 3D support'
+ 'lib32-vulkan-icd-loader: Vulkan support'
+ 'linux-steam-integration: start Steam with LSI'
+ "mangohud: Display the games' FPS + other information"
+ 'vkd3d: Vulkan 3D support'
+ 'vulkan-icd-loader: Vulkan support'
+ 'wine: easiest way to get all the libraries missing from the Lutris runtime'
+ 'winetricks: use system winetricks'
+ 'xorg-xgamma: Restore gamma on game exit')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/lutris/lutris.git')