summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 131964068d27..a757083238df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.10.1.r73.gf6e7d86b
+ pkgver = 0.5.10.1.r143.g069b098a
pkgrel = 1
url = https://lutris.net/
arch = any
@@ -47,6 +47,8 @@ pkgbase = lutris-git
provides = lutris
conflicts = lutris
source = git+https://github.com/lutris/lutris.git
+ source = https://github.com/lutris/lutris/pull/4395.patch
sha256sums = SKIP
+ sha256sums = 718a3beb54ea15bcadda40dbd463afd3e5e05f91bb417f2e73f88c111aca93e4
pkgname = lutris-git
diff --git a/PKGBUILD b/PKGBUILD
index a697cc096649..d5b9d4907975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.10.1.r73.gf6e7d86b
+pkgver=0.5.10.1.r143.g069b098a
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -40,14 +40,24 @@ optdepends=(
'xorg-xgamma: Restore gamma on game exit')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/lutris/lutris.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lutris/lutris.git'
+ 'https://github.com/lutris/lutris/pull/4395.patch')
+sha256sums=('SKIP'
+ '718a3beb54ea15bcadda40dbd463afd3e5e05f91bb417f2e73f88c111aca93e4')
pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Correct syntax of fi.po
+ # https://github.com/lutris/lutris/issues/4394
+ patch -Np1 -i ../4395.patch
+}
+
build() {
arch-meson "${pkgname%-git}" build
meson compile -C build