summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f84c8376fcf6..07335f18f2ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.8.2.r13.g5d5736b5
+ pkgver = 0.5.8.2.r12.g1b321f40
pkgrel = 1
url = https://lutris.net/
arch = any
@@ -18,23 +18,24 @@ pkgbase = lutris-git
depends = unzip
depends = p7zip
depends = curl
- depends = xorg-xrandr
depends = python-pillow
depends = python-requests
- depends = gnome-desktop
depends = webkit2gtk
depends = mesa-demos
depends = python-dbus
depends = python-distro
depends = python-magic-ahupp
depends = python-lxml
- optdepends = wine: Run windows games
+ optdepends = wine: easiest way to get all the libraries missing from the Lutris runtime
optdepends = vulkan-icd-loader: Vulkan support
optdepends = lib32-vulkan-icd-loader: Vulkan support
optdepends = vkd3d: Vulkan 3D support
optdepends = lib32-vkd3d: Vulkan 3D support
optdepends = gvfs: GVFS backend
- optdepends = python-evdev: Detecting connected joypads
+ optdepends = xorg-xrandr: fetch screen resolutions on Xorg
+ optdepends = gnome-desktop: fetch screen resolutions on Wayland
+ optdepends = lib32-glibc: for 32bit games support
+ optdepends = python-evdev: for controller detection
optdepends = python-pypresence: Discord RPC and Rich Presence
optdepends = gamemode: Allows games to request a temporary set of optimisations
optdepends = mangohud: Display the games' FPS + other information
diff --git a/PKGBUILD b/PKGBUILD
index 5552a12143a1..604ef59f4d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,30 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.8.2.r13.g5d5736b5
+pkgver=0.5.8.2.r12.g1b321f40
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
url='https://lutris.net/'
license=('GPL3')
depends=('python-gobject' 'python-yaml' 'python-evdev' 'python-dbus' 'gtk3'
- 'glib2' 'psmisc' 'cabextract' 'unzip' 'p7zip' 'curl' 'xorg-xrandr'
- 'python-pillow' 'python-requests' 'gnome-desktop' 'webkit2gtk'
+ 'glib2' 'psmisc' 'cabextract' 'unzip' 'p7zip' 'curl'
+ 'python-pillow' 'python-requests' 'webkit2gtk'
'mesa-demos' 'python-dbus' 'python-distro' 'python-magic-ahupp'
'python-lxml')
makedepends=('git' 'meson')
#checkdepends=('xorg-server-xvfb' 'python-nose-cover3' 'wine' 'xterm')
optdepends=(
- 'wine: Run windows games'
+ 'wine: easiest way to get all the libraries missing from the Lutris runtime'
'vulkan-icd-loader: Vulkan support'
'lib32-vulkan-icd-loader: Vulkan support'
'vkd3d: Vulkan 3D support'
'lib32-vkd3d: Vulkan 3D support'
'gvfs: GVFS backend'
- 'python-evdev: Detecting connected joypads'
+ 'xorg-xrandr: fetch screen resolutions on Xorg'
+ 'gnome-desktop: fetch screen resolutions on Wayland'
+ 'lib32-glibc: for 32bit games support'
+ 'python-evdev: for controller detection'
'python-pypresence: Discord RPC and Rich Presence'
'gamemode: Allows games to request a temporary set of optimisations'
"mangohud: Display the games' FPS + other information")
@@ -51,7 +54,6 @@ check() {
# cd "$srcdir/${pkgname%-git}"
# xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml \
# --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
-
}
package() {