summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--test-fix.patch22
3 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf985a57daf..86bfa6c09a52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.7.1.r232.g3edfd15b
+ pkgver = 0.5.7.1.r274.g88e4ffa6
pkgrel = 1
url = https://lutris.net/
arch = any
@@ -44,7 +44,9 @@ pkgbase = lutris-git
provides = lutris
conflicts = lutris
source = git+https://github.com/lutris/lutris.git
+ source = test-fix.patch
sha256sums = SKIP
+ sha256sums = 2e627ec7ddcfcc4c5180cb837163966705288c18cc75447872df6c669c9c7516
pkgname = lutris-git
diff --git a/PKGBUILD b/PKGBUILD
index d6fa1e0c4035..31002a033541 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=lutris-git
_pkgname=lutris
-pkgver=0.5.7.1.r232.g3edfd15b
+pkgver=0.5.7.1.r274.g88e4ffa6
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -29,8 +29,10 @@ optdepends=(
'python-pypresence: Discord RPC and Rich Presence')
provides=('lutris')
conflicts=('lutris')
-source=('git+https://github.com/lutris/lutris.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lutris/lutris.git'
+ 'test-fix.patch')
+sha256sums=('SKIP'
+ '2e627ec7ddcfcc4c5180cb837163966705288c18cc75447872df6c669c9c7516')
pkgver() {
cd ${_pkgname}
@@ -46,7 +48,7 @@ build() {
check() {
cd ${_pkgname}
-
+ patch --strip=1 --input="${srcdir}/test-fix.patch"
xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
}
diff --git a/test-fix.patch b/test-fix.patch
new file mode 100644
index 000000000000..e37596552808
--- /dev/null
+++ b/test-fix.patch
@@ -0,0 +1,22 @@
+From 11aed2b2c07331903936caa5f70d20a150069996 Mon Sep 17 00:00:00 2001
+From: harre <mail@hartmark.se>
+Date: Sun, 11 Oct 2020 00:25:01 +0200
+Subject: [PATCH] Fix failing test #3192
+
+---
+ tests/test_dialogs.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_dialogs.py b/tests/test_dialogs.py
+index a7cefa316..8dc89f087 100644
+--- a/tests/test_dialogs.py
++++ b/tests/test_dialogs.py
+@@ -102,7 +102,7 @@ def test_can_add_game(self):
+ self.assertTrue(pga_game)
+ game = Game(pga_game['id'])
+ self.assertEqual(game.name, 'Test game')
+- game.remove(from_library=True)
++ game.remove()
+
+
+ class TestSort(TestCase):