summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--python.patch4
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 608cff40328a..8839cf6defcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luxcorerender-git
pkgdesc = Physically correct, unbiased rendering engine.
- pkgver = 2.3.r80.gc68d73748
+ pkgver = 2.3.r90.ged325009a
pkgrel = 1
epoch = 2
url = https://www.luxcorerender.org/
@@ -31,10 +31,10 @@ pkgbase = luxcorerender-git
source = python.patch
source = glfw.patch
source = boost016900_serialization.patch
- md5sums = SKIP
- md5sums = 8e2fd7337fe6afaf5b2801426837f600
- md5sums = e2a20172b7b7ac92a7002b6218afe327
- md5sums = 52f097678654151e2b5427d271a7e69d
+ sha256sums = SKIP
+ sha256sums = 92bf04a12ce6a1f559eb3b129e324e0349e3b9f8da1976dae6e16704a031b359
+ sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
+ sha256sums = 495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760
pkgname = luxcorerender-git
diff --git a/PKGBUILD b/PKGBUILD
index 754e137f71c8..cb2c771cf25b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name="luxcorerender"
_ver_tag="luxcorerender_v2.2"
{ IFS='.'; read _ver_major _ver_minor; ((_ver_minor++)); unset IFS; } <<<${_ver_tag#luxcorerender_v}
pkgname=${_name}-git
-pkgver=2.3.r80.gc68d73748
+pkgver=2.3.r90.ged325009a
epoch=2
pkgrel=1
pkgdesc="Physically correct, unbiased rendering engine."
@@ -23,10 +23,10 @@ source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"glfw.patch"
"boost016900_serialization.patch"
)
-md5sums=('SKIP'
- '8e2fd7337fe6afaf5b2801426837f600'
- 'e2a20172b7b7ac92a7002b6218afe327'
- '52f097678654151e2b5427d271a7e69d')
+sha256sums=('SKIP'
+ '92bf04a12ce6a1f559eb3b129e324e0349e3b9f8da1976dae6e16704a031b359'
+ '4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
+ '495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760')
pkgver() {
cd ${srcdir}/${_name}
diff --git a/python.patch b/python.patch
index 51bede663a3f..287cbb1c0f68 100644
--- a/python.patch
+++ b/python.patch
@@ -72,5 +72,5 @@ index c8d9c4aa9..1dc6b7c63 100644
add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
--TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})