summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--12-boost179-fstream.patch37
-rw-r--r--13-sdlog.patch174
-rw-r--r--14-fmt9.patch107
-rw-r--r--PKGBUILD15
5 files changed, 342 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80eb255839e5..c02ec5bbe15a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,6 +24,9 @@ pkgbase = luxcorerender-git
depends = openimagedenoise
depends = openimageio
depends = openvdb
+ depends = fmt9
+ depends = python
+ depends = spdlog
optdepends = opencl-driver: for gpu acceleration
optdepends = pyside2: for pyluxcoretools gui
provides = luxrays
@@ -42,6 +45,9 @@ pkgbase = luxcorerender-git
source = 10-spdlog.patch
source = 11-openimageio.patch
source = 11-opencolorio.patch
+ source = 12-boost179-fstream.patch
+ source = 13-sdlog.patch
+ source = 14-fmt9.patch
sha256sums = SKIP
sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
sha256sums = f5fc0bbeb09c95750da6ca668ea2f26b84998c57c9abb8ac0a3d96131017f66d
@@ -54,6 +60,9 @@ pkgbase = luxcorerender-git
sha256sums = 10375ea78ab9c1454211992179368a9fa84b79700a4a2ef2b47cb2f1c908699b
sha256sums = bdf0e8167a4e26cc251846b4b8a8827571f8ac9478f7a2400f6776bfe6b99375
sha256sums = 6c34263d955440cb200ddb6f51711fca9b5548ca9ccf133cc924f87298f4dce0
+ sha256sums = 069ca9caef3b7c85ffc4a55de79122488b1b513135b0536b24772c483c8d0cab
+ sha256sums = 073c5d86983b376bc72a7ab9f41de7bd50f9aff54a7b7b2b5bcd3c17eba9937e
+ sha256sums = e4ad9b7a0b77e0ca00136159f8f7c8e5940d26918421f18114ad5657fbf32359
b2sums = SKIP
b2sums = 2903992389c61fc4720cde8a011d0b637de647a7c9e701609968c01a8ab904277dfb27a90179d4cfcf98382973542e59d1384580236c25f6568aaa7b6ba90528
b2sums = 3057084619ac9067883b820d6ca4cb896155b587a09b689aa2a0dd1139478577164cfe90d5165d84cb88850b35fc5721ad76568764f555bd5c05b8e394c95b48
@@ -66,5 +75,8 @@ pkgbase = luxcorerender-git
b2sums = 798b7e21d44f8c68022b5f212f0235ef1558629db2d7356128b23736a9f97009cc85f48c77e30f5908832da46204d54444f0221675e917d3e3f85c0027c547dd
b2sums = 537301a740c8cbbb45905d28d8fb58069e3839020208e911515a4c0e7aba39bf3d5d53699ee54b42efead2d499b30f1fb77e5dde3aa7faadd0ac9bd45445f8dd
b2sums = 19a81a9c442272e7d0123bc99b93be8cafab1a84a7a9bbb58e92e5a6624277e85b33c41183e739ebb8898aa886d477854c9075457a4da9266a5a8a0b26387ae0
+ b2sums = 1d434b3eb400af3b4db9ad1fd3f40d8cfcae6d7adcb0912f3fb243f5f824f1df72b6ccd044fc22d7ca5b7476e58ce3ffce0eadbe5d9e8f5a07ab9fcecc85b776
+ b2sums = 7a3d9b0e29993c6c34166c0b582a1d464751c0e5c46f643a4ee3fcd1e1dbad98e935dc4ce4d6de3e419d94f46b12514214806abe91722c880bf251c9de8ee953
+ b2sums = 084628e44473a2ddb5fdcffb5ddab5dabf02aee46de01a3a0f22f0ffab958be3980494078a7b4b2fcd2168a4d048de13ac14cecd26dda97ff00037e41ca50c11
pkgname = luxcorerender-git
diff --git a/12-boost179-fstream.patch b/12-boost179-fstream.patch
new file mode 100644
index 000000000000..4e1a5a1c9824
--- /dev/null
+++ b/12-boost179-fstream.patch
@@ -0,0 +1,37 @@
+From a6fa314427f99b3d24018490e8dfa18177184445 Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Sun, 3 Jul 2022 20:02:31 +0200
+Subject: [PATCH 12/14] boost179 fstream
+
+---
+ src/luxrays/utils/cuda.cpp | 1 +
+ src/luxrays/utils/ocl.cpp | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/luxrays/utils/cuda.cpp b/src/luxrays/utils/cuda.cpp
+index 6ae9e9f42..888e12497 100644
+--- a/src/luxrays/utils/cuda.cpp
++++ b/src/luxrays/utils/cuda.cpp
+@@ -24,6 +24,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/algorithm/string/trim.hpp>
++#include <boost/filesystem/fstream.hpp>
+
+ #include "luxrays/luxrays.h"
+ #include "luxrays/utils/utils.h"
+diff --git a/src/luxrays/utils/ocl.cpp b/src/luxrays/utils/ocl.cpp
+index 785836cef..80b7a8f45 100644
+--- a/src/luxrays/utils/ocl.cpp
++++ b/src/luxrays/utils/ocl.cpp
+@@ -24,6 +24,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/algorithm/string/trim.hpp>
++#include <boost/filesystem/fstream.hpp>
+
+ #include "luxrays/luxrays.h"
+ #include "luxrays/utils/utils.h"
+--
+2.41.0
+
diff --git a/13-sdlog.patch b/13-sdlog.patch
new file mode 100644
index 000000000000..ab5b07768959
--- /dev/null
+++ b/13-sdlog.patch
@@ -0,0 +1,174 @@
+From 0d29db229c7d403545eff2e64f35a1170836f7ce Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Sat, 21 May 2022 18:20:14 +0200
+Subject: [PATCH 13/14] spdlog
+
+---
+ CMakeLists.txt | 6 +++++-
+ deps/spdlog-1.8.0/include/spdlog/common-inl.h | 2 +-
+ include/luxcore/luxcorelogger.h | 2 +-
+ include/luxcore/luxcoresink.h | 2 +-
+ samples/luxcoreconsole/CMakeLists.txt | 3 ++-
+ samples/luxcoredemo/CMakeLists.txt | 3 ++-
+ samples/luxcorescenedemo/CMakeLists.txt | 3 ++-
+ samples/luxcoreui/CMakeLists.txt | 6 +++++-
+ src/luxcore/luxcore.cpp | 2 +-
+ src/luxcore/luxcoreinit.cpp | 6 +++---
+ tests/luxcoreimplserializationdemo/CMakeLists.txt | 3 ++-
+ 11 files changed, 25 insertions(+), 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 586ca9ece..c0da2b5d5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -107,12 +107,16 @@ include_directories("${LuxRays_SOURCE_DIR}/deps/json-3.7.3/include")
+ include_directories("${LuxRays_SOURCE_DIR}/deps/cuew/include")
+ include_directories("${LuxRays_SOURCE_DIR}/deps/clew/include")
+ include_directories("${LuxRays_SOURCE_DIR}/deps/optix-7.1.0/include")
+-include_directories("${LuxRays_SOURCE_DIR}/deps/spdlog-1.8.0/include")
++#include_directories("${LuxRays_SOURCE_DIR}/deps/spdlog-1.8.0/include")
+ include_directories("${LuxRays_SOURCE_DIR}/deps/robin-hood-hashing-3.9.1/src/include")
+
+ # Find dependencies
+ include(Dependencies)
+
++add_definitions(-DSPDLOG_FMT_EXTERNAL=1)
++find_package(spdlog REQUIRED)
++include_directories(${SPDLOG_INCLUDE_DIRS})
++
+ SET(Boost_Save ${Boost_LIBRARIES})
+ find_package(OpenVDB)
+ LIST(APPEND Boost_LIBRARIES ${Boost_Save})
+diff --git a/include/luxcore/luxcorelogger.h b/include/luxcore/luxcorelogger.h
+index ecf979893..030f891f2 100644
+--- a/include/luxcore/luxcorelogger.h
++++ b/include/luxcore/luxcorelogger.h
+@@ -22,7 +22,7 @@
+ #include <memory>
+ #include <sstream>
+
+-#include "spdlog/spdlog.h"
++#include <spdlog/spdlog.h>
+
+ #include "luxrays/utils/strutils.h"
+ #include "luxrays/utils/properties.h"
+diff --git a/include/luxcore/luxcoresink.h b/include/luxcore/luxcoresink.h
+index a7207a027..0e8528dd8 100644
+--- a/include/luxcore/luxcoresink.h
++++ b/include/luxcore/luxcoresink.h
+@@ -21,7 +21,7 @@
+
+ #include <mutex>
+
+-#include "spdlog/sinks/rotating_file_sink.h"
++#include <spdlog/sinks/rotating_file_sink.h>
+
+ //------------------------------------------------------------------------------
+ // Our SpdLog sink for LuxCore call back handler
+diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
+index 638bcd1da..bd9a73651 100644
+--- a/samples/luxcoreconsole/CMakeLists.txt
++++ b/samples/luxcoreconsole/CMakeLists.txt
+@@ -27,9 +27,10 @@ set(LUXCORECONSOLE_SRCS
+ )
+
+ add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
++find_package(fmt REQUIRED)
+
+ if(APPLE)
+ TARGET_LINK_LIBRARIES(luxcoreconsole expat "-framework Carbon" "-framework IOKit" ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
+ else()
+-TARGET_LINK_LIBRARIES(luxcoreconsole opencolorio ${OpenVDB_LIBRARIES} ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
++ TARGET_LINK_LIBRARIES(luxcoreconsole opencolorio ${OpenVDB_LIBRARIES} ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} fmt::fmt)
+ endif()
+diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
+index c7ac7ac77..e2f5d114a 100644
+--- a/samples/luxcoredemo/CMakeLists.txt
++++ b/samples/luxcoredemo/CMakeLists.txt
+@@ -28,5 +28,6 @@ set(LUXCORELIBDEMO_SRCS
+
+ add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
++find_package(fmt REQUIRED)
+
+-TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES} ${OpenVDB_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
+index f428305ec..5a010f325 100644
+--- a/samples/luxcorescenedemo/CMakeLists.txt
++++ b/samples/luxcorescenedemo/CMakeLists.txt
+@@ -28,5 +28,6 @@ set(LUXCORESCENEDEMO_SRCS
+
+ add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
++find_package(fmt REQUIRED)
+
+-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OpenVDB_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index 92f1784f7..c06be0fb6 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -85,6 +85,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ ENDIF()
+
+ add_executable(luxcoreui ${LUXCOREUI_SRCS})
++find_package(fmt REQUIRED)
+
+ if(APPLE)
+
+@@ -105,5 +106,8 @@ TARGET_LINK_LIBRARIES(luxcoreui
+ ${GTK3_LIBRARIES}
+ ${Boost_LIBRARIES}
+ ${PYTHON_LIBRARIES}
+- ${OpenVDB_LIBRARIES})
++ ${OpenVDB_LIBRARIES}
++ ${FMT_LIBRARIES}
++ fmt::fmt
++ )
+ endif()
+diff --git a/src/luxcore/luxcore.cpp b/src/luxcore/luxcore.cpp
+index ab754faac..2a86bc817 100644
+--- a/src/luxcore/luxcore.cpp
++++ b/src/luxcore/luxcore.cpp
+@@ -19,7 +19,7 @@
+ #include <OpenImageIO/imagebuf.h>
+ #include <OpenImageIO/imagebufalgo.h>
+
+-#include "spdlog/spdlog.h"
++#include <spdlog/spdlog.h>
+
+ #include "luxrays/core/intersectiondevice.h"
+ #include "luxrays/utils/utils.h"
+diff --git a/src/luxcore/luxcoreinit.cpp b/src/luxcore/luxcoreinit.cpp
+index 489968516..b6cee09a0 100644
+--- a/src/luxcore/luxcoreinit.cpp
++++ b/src/luxcore/luxcoreinit.cpp
+@@ -20,9 +20,9 @@
+ #include <boost/format.hpp>
+ #include <boost/thread/mutex.hpp>
+
+-#include "spdlog/spdlog.h"
+-#include "spdlog/sinks/rotating_file_sink.h"
+-#include "spdlog/sinks/null_sink.h"
++#include <spdlog/spdlog.h>
++#include <spdlog/sinks/rotating_file_sink.h>
++#include <spdlog/sinks/null_sink.h>
+
+ #include "luxrays/luxrays.h"
+ #include "luxrays/utils/strutils.h"
+diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+index 8f458eda1..276851016 100644
+--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
++++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+@@ -30,5 +30,6 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
+ include_directories(${LuxRays_SOURCE_DIR}/deps/opencolorio-2.0.0/include)
+
+ add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
++find_package(fmt)
+
+-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv opencolorio ${OpenVDB_LIBRARIES} ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv opencolorio ${OpenVDB_LIBRARIES} ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} fmt::fmt)
+--
+2.43.0
+
diff --git a/14-fmt9.patch b/14-fmt9.patch
new file mode 100644
index 000000000000..77815a814f9a
--- /dev/null
+++ b/14-fmt9.patch
@@ -0,0 +1,107 @@
+From df8c3049c6b7cd822d21a18d295a8c653e153c03 Mon Sep 17 00:00:00 2001
+From: howetuft <howetuft@gmail.com>
+Date: Wed, 16 Aug 2023 20:05:05 +0200
+Subject: [PATCH 14/14] fmt9
+
+---
+ CMakeLists.txt | 3 +++
+ samples/luxcoreconsole/CMakeLists.txt | 2 +-
+ samples/luxcoredemo/CMakeLists.txt | 2 +-
+ samples/luxcorescenedemo/CMakeLists.txt | 2 +-
+ samples/luxcoreui/CMakeLists.txt | 2 +-
+ src/luxcore/CMakeLists.txt | 2 +-
+ tests/luxcoreimplserializationdemo/CMakeLists.txt | 2 +-
+ 7 files changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c0da2b5d5..f0067dc1a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -116,6 +116,9 @@ include(Dependencies)
+ add_definitions(-DSPDLOG_FMT_EXTERNAL=1)
+ find_package(spdlog REQUIRED)
+ include_directories(${SPDLOG_INCLUDE_DIRS})
++find_package(fmt 9.0.0...<10.0.0 CONFIG)
++get_target_property(FMT_INCLUDE_DIRECTORIES fmt::fmt INTERFACE_INCLUDE_DIRECTORIES)
++include_directories(${FMT_INCLUDE_DIRECTORIES})
+
+ SET(Boost_Save ${Boost_LIBRARIES})
+ find_package(OpenVDB)
+diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
+index bd9a73651..f302c4734 100644
+--- a/samples/luxcoreconsole/CMakeLists.txt
++++ b/samples/luxcoreconsole/CMakeLists.txt
+@@ -27,7 +27,7 @@ set(LUXCORECONSOLE_SRCS
+ )
+
+ add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ if(APPLE)
+ TARGET_LINK_LIBRARIES(luxcoreconsole expat "-framework Carbon" "-framework IOKit" ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
+diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
+index e2f5d114a..879929554 100644
+--- a/samples/luxcoredemo/CMakeLists.txt
++++ b/samples/luxcoredemo/CMakeLists.txt
+@@ -28,6 +28,6 @@ set(LUXCORELIBDEMO_SRCS
+
+ add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
+index 5a010f325..389784e18 100644
+--- a/samples/luxcorescenedemo/CMakeLists.txt
++++ b/samples/luxcorescenedemo/CMakeLists.txt
+@@ -28,6 +28,6 @@ set(LUXCORESCENEDEMO_SRCS
+
+ add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
+ add_definitions(${VISIBILITY_FLAGS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OpenVDB_LIBRARIES} fmt::fmt)
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index c06be0fb6..b6ff48570 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -85,7 +85,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ ENDIF()
+
+ add_executable(luxcoreui ${LUXCOREUI_SRCS})
+-find_package(fmt REQUIRED)
++find_package(fmt 9.0.0...<10.0.0 REQUIRED)
+
+ if(APPLE)
+
+diff --git a/src/luxcore/CMakeLists.txt b/src/luxcore/CMakeLists.txt
+index 4a3fa76e9..f3bb5f3f4 100644
+--- a/src/luxcore/CMakeLists.txt
++++ b/src/luxcore/CMakeLists.txt
+@@ -182,7 +182,7 @@ if(APPLE)
+ target_link_libraries(pyluxcore -Wl,-undefined -Wl,dynamic_lookup slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb opencolorio expat ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+ SET_TARGET_PROPERTIES(pyluxcore PROPERTIES XCODE_ATTRIBUTE_DEPLOYMENT_POSTPROCESSING NO) # exclude pylux from strip, not possible
+ else()
+- target_link_libraries(pyluxcore PRIVATE slg-core slg-film slg-kernels luxrays bcd opensubdiv ${OpenVDB_LIBRARIES} opencolorio ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++ target_link_libraries(pyluxcore PRIVATE slg-core slg-film slg-kernels luxrays bcd opensubdiv ${OpenVDB_LIBRARIES} opencolorio ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} fmt::fmt)
+ endif()
+
+ set_target_properties(pyluxcore PROPERTIES PREFIX "")
+diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+index 276851016..39de31bbf 100644
+--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
++++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+@@ -30,6 +30,6 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
+ include_directories(${LuxRays_SOURCE_DIR}/deps/opencolorio-2.0.0/include)
+
+ add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
+-find_package(fmt)
++find_package(fmt 9.0.0...<10.0.0)
+
+ TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv opencolorio ${OpenVDB_LIBRARIES} ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES} ${PYTHON_LIBRARIES} fmt::fmt)
+--
+2.41.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 0be8a1ca7618..b5fccad8524e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ pkgdesc="Physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
license=('Apache')
-depends+=(blosc boost-libs embree3 glfw gtk3 openimagedenoise openimageio openvdb)
+depends+=(blosc boost-libs embree3 glfw gtk3 openimagedenoise openimageio openvdb fmt9 python spdlog)
optdepends+=("pyside2: for pyluxcoretools gui")
makedepends+=(boost cmake doxygen git ninja pyside2-tools pyside6-tools-wrappers)
conflicts=(luxcorerender)
@@ -45,6 +45,9 @@ source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"10-spdlog.patch"
"11-openimageio.patch"
"11-opencolorio.patch"
+ "12-boost179-fstream.patch"
+ "13-sdlog.patch"
+ "14-fmt9.patch"
)
sha256sums=('SKIP'
'4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
@@ -57,7 +60,10 @@ sha256sums=('SKIP'
'affd6f2808d233cb1bbf92fa35c4b02a8ca160fccbe5500e3d4d277b6396f75f'
'10375ea78ab9c1454211992179368a9fa84b79700a4a2ef2b47cb2f1c908699b'
'bdf0e8167a4e26cc251846b4b8a8827571f8ac9478f7a2400f6776bfe6b99375'
- '6c34263d955440cb200ddb6f51711fca9b5548ca9ccf133cc924f87298f4dce0')
+ '6c34263d955440cb200ddb6f51711fca9b5548ca9ccf133cc924f87298f4dce0'
+ '069ca9caef3b7c85ffc4a55de79122488b1b513135b0536b24772c483c8d0cab'
+ '073c5d86983b376bc72a7ab9f41de7bd50f9aff54a7b7b2b5bcd3c17eba9937e'
+ 'e4ad9b7a0b77e0ca00136159f8f7c8e5940d26918421f18114ad5657fbf32359')
b2sums=('SKIP'
'2903992389c61fc4720cde8a011d0b637de647a7c9e701609968c01a8ab904277dfb27a90179d4cfcf98382973542e59d1384580236c25f6568aaa7b6ba90528'
'3057084619ac9067883b820d6ca4cb896155b587a09b689aa2a0dd1139478577164cfe90d5165d84cb88850b35fc5721ad76568764f555bd5c05b8e394c95b48'
@@ -69,7 +75,10 @@ b2sums=('SKIP'
'db503abd1f18c2d0a035bc7c8e11e9430427cc153a241834642837b7189b570fa474fada146cab0ea96d7fd666ceb300115013340f411f657713aa9256545b36'
'798b7e21d44f8c68022b5f212f0235ef1558629db2d7356128b23736a9f97009cc85f48c77e30f5908832da46204d54444f0221675e917d3e3f85c0027c547dd'
'537301a740c8cbbb45905d28d8fb58069e3839020208e911515a4c0e7aba39bf3d5d53699ee54b42efead2d499b30f1fb77e5dde3aa7faadd0ac9bd45445f8dd'
- '19a81a9c442272e7d0123bc99b93be8cafab1a84a7a9bbb58e92e5a6624277e85b33c41183e739ebb8898aa886d477854c9075457a4da9266a5a8a0b26387ae0')
+ '19a81a9c442272e7d0123bc99b93be8cafab1a84a7a9bbb58e92e5a6624277e85b33c41183e739ebb8898aa886d477854c9075457a4da9266a5a8a0b26387ae0'
+ '1d434b3eb400af3b4db9ad1fd3f40d8cfcae6d7adcb0912f3fb243f5f824f1df72b6ccd044fc22d7ca5b7476e58ce3ffce0eadbe5d9e8f5a07ab9fcecc85b776'
+ '7a3d9b0e29993c6c34166c0b582a1d464751c0e5c46f643a4ee3fcd1e1dbad98e935dc4ce4d6de3e419d94f46b12514214806abe91722c880bf251c9de8ee953'
+ '084628e44473a2ddb5fdcffb5ddab5dabf02aee46de01a3a0f22f0ffab958be3980494078a7b4b2fcd2168a4d048de13ac14cecd26dda97ff00037e41ca50c11')
pkgver() {
# shellcheck disable=SC2164