summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--lvce.sh2
3 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ef16a9e6fc8..9060ab1a63f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.16.15
+ pkgver = 0.16.17
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = x86_64
license = MIT
makedepends = asar
- depends = electron
- optdepends = bash
+ depends = bash
+ depends = electron25
provides = lvce
conflicts = lvce
- conflicts = lvce-appimage
- source = lvce-0.16.15.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.16.15/lvce-v0.16.15_amd64.deb
+ source = lvce-0.16.17.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.16.17/lvce-v0.16.17_amd64.deb
source = LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/main/LICENSE
source = lvce.sh
- sha256sums = 5fe237f7ae5937946cc5960d288953d6aafc30c29475e1ad1b04b6e201679ea4
+ sha256sums = 7ba7d82209f29955280f0920e39704c25da1457e8f048acc87c6cfbb3d378971
sha256sums = 7736b1dbda2b18af09232f9eb619e4d3d79d855058cc7494853f25d1553ed00b
sha256sums = 430a6ffca93f056ee621dbea385ea21797d08046e753a6b033a04e320387cef5
diff --git a/PKGBUILD b/PKGBUILD
index 12b42d8afb98..63ad35e25028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.16.15
+pkgver=0.16.17
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=('x86_64')
url="https://lvce-editor.github.io/lvce-editor"
_githuburl="https://github.com/lvce-editor/lvce-editor"
license=('MIT')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
provides=("${pkgname%-bin}")
-depends=('electron')
-optdepends=('bash')
+conflicts=("${pkgname%-bin}")
+depends=('bash' 'electron25')
makedepends=('asar')
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb"
"LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/main/LICENSE"
"${pkgname%-bin}.sh")
-sha256sums=('5fe237f7ae5937946cc5960d288953d6aafc30c29475e1ad1b04b6e201679ea4'
+sha256sums=('7ba7d82209f29955280f0920e39704c25da1457e8f048acc87c6cfbb3d378971'
'7736b1dbda2b18af09232f9eb619e4d3d79d855058cc7494853f25d1553ed00b'
'430a6ffca93f056ee621dbea385ea21797d08046e753a6b033a04e320387cef5')
package() {
diff --git a/lvce.sh b/lvce.sh
index c583a24b72aa..993c76cf1a84 100644
--- a/lvce.sh
+++ b/lvce.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron
+_ELECTRON=/usr/bin/electron25
_ASAR="/opt/lvce/lvce.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"