summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ffe2c35e4c1..c762af89ff7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.17.18
+ pkgver = 0.18.1
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -31,16 +31,16 @@ pkgbase = lvce-bin
depends = libxkbcommon
depends = libxcb
depends = cairo
- provides = lvce=0.17.18
+ provides = lvce=0.18.1
conflicts = lvce
options = !strip
- source = LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v0.17.18/LICENSE
- sha256sums = 7736b1dbda2b18af09232f9eb619e4d3d79d855058cc7494853f25d1553ed00b
- source_aarch64 = lvce-0.17.18-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.17.18/lvce-v0.17.18_arm64.deb
- sha256sums_aarch64 = 888d916e2e081e167b3af28daf6cdae7c37eeb48e3b53d4786aec34b642f8bbe
- source_armv7h = lvce-0.17.18-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.17.18/lvce-v0.17.18_armhf.deb
- sha256sums_armv7h = 4a839fcb99094a736e84f2eb6495d02f555cfe56c8d078ec56a422d3a7fdda7e
- source_x86_64 = lvce-0.17.18-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.17.18/lvce-v0.17.18_amd64.deb
- sha256sums_x86_64 = 8daa602a4927c0b953c20e1483e4d79f5b75efab299913e6e1b57473da024d4e
+ source = LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v0.18.1/LICENSE
+ sha256sums = bcb1a9f42beeababd8267db00d5b7bfec20e671b8c47374b80dbd25b655146ec
+ source_aarch64 = lvce-0.18.1-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_arm64.deb
+ sha256sums_aarch64 = 4867129cc56f753e633bc88afb33e12bcce09f36c64f21a8e999abf3368e7878
+ source_armv7h = lvce-0.18.1-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_armhf.deb
+ sha256sums_armv7h = 72e3a368fe32d522f3f1ad45d528ef2ee3528eb01763f6f9374460a8e79185fb
+ source_x86_64 = lvce-0.18.1-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_amd64.deb
+ sha256sums_x86_64 = 9408e741e4362a63b615693ffefb7047f8d00f984653e724e37820bae0a104d3
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index b4a864fb74fa..edda437b749b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.17.18
+pkgver=0.18.1
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=('aarch64' 'armv7h' 'x86_64')
@@ -16,10 +16,10 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/d
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_armhf.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb")
source=("LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v${pkgver}/LICENSE")
-sha256sums=('7736b1dbda2b18af09232f9eb619e4d3d79d855058cc7494853f25d1553ed00b')
-sha256sums_aarch64=('888d916e2e081e167b3af28daf6cdae7c37eeb48e3b53d4786aec34b642f8bbe')
-sha256sums_armv7h=('4a839fcb99094a736e84f2eb6495d02f555cfe56c8d078ec56a422d3a7fdda7e')
-sha256sums_x86_64=('8daa602a4927c0b953c20e1483e4d79f5b75efab299913e6e1b57473da024d4e')
+sha256sums=('bcb1a9f42beeababd8267db00d5b7bfec20e671b8c47374b80dbd25b655146ec')
+sha256sums_aarch64=('4867129cc56f753e633bc88afb33e12bcce09f36c64f21a8e999abf3368e7878')
+sha256sums_armv7h=('72e3a368fe32d522f3f1ad45d528ef2ee3528eb01763f6f9374460a8e79185fb')
+sha256sums_x86_64=('9408e741e4362a63b615693ffefb7047f8d00f984653e724e37820bae0a104d3')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s| %U| --no-sandbox %U|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"