summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD8
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c762af89ff7d..c7c4d6ade047 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.18.1
+ pkgver = 0.18.8
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -31,16 +31,16 @@ pkgbase = lvce-bin
depends = libxkbcommon
depends = libxcb
depends = cairo
- provides = lvce=0.18.1
+ provides = lvce=0.18.8
conflicts = lvce
options = !strip
- source = LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v0.18.1/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v0.18.8/LICENSE
sha256sums = bcb1a9f42beeababd8267db00d5b7bfec20e671b8c47374b80dbd25b655146ec
- source_aarch64 = lvce-0.18.1-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_arm64.deb
- sha256sums_aarch64 = 4867129cc56f753e633bc88afb33e12bcce09f36c64f21a8e999abf3368e7878
- source_armv7h = lvce-0.18.1-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_armhf.deb
- sha256sums_armv7h = 72e3a368fe32d522f3f1ad45d528ef2ee3528eb01763f6f9374460a8e79185fb
- source_x86_64 = lvce-0.18.1-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.1/lvce-v0.18.1_amd64.deb
- sha256sums_x86_64 = 9408e741e4362a63b615693ffefb7047f8d00f984653e724e37820bae0a104d3
+ source_aarch64 = lvce-0.18.8-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.8/lvce-v0.18.8_arm64.deb
+ sha256sums_aarch64 = 2a2efc302fcf30c72d6b70f7df216855cc1b0618ed62c2ad8a481dfc0d7f6e79
+ source_armv7h = lvce-0.18.8-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.8/lvce-v0.18.8_armhf.deb
+ sha256sums_armv7h = a60ed4068ccced533ec124dfd4b3fec0259383f7a951fa7fd620e5e6c79d256d
+ source_x86_64 = lvce-0.18.8-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.8/lvce-v0.18.8_amd64.deb
+ sha256sums_x86_64 = 59961845417ae938a8534172c24cedeb6464a19cfa554d9587960f70152cb42e
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index edda437b749b..35ee94ab87bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.18.1
+pkgver=0.18.8
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=('aarch64' 'armv7h' 'x86_64')
@@ -17,9 +17,9 @@ source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_githuburl}/releases/dow
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb")
source=("LICENSE::https://raw.githubusercontent.com/lvce-editor/lvce-editor/v${pkgver}/LICENSE")
sha256sums=('bcb1a9f42beeababd8267db00d5b7bfec20e671b8c47374b80dbd25b655146ec')
-sha256sums_aarch64=('4867129cc56f753e633bc88afb33e12bcce09f36c64f21a8e999abf3368e7878')
-sha256sums_armv7h=('72e3a368fe32d522f3f1ad45d528ef2ee3528eb01763f6f9374460a8e79185fb')
-sha256sums_x86_64=('9408e741e4362a63b615693ffefb7047f8d00f984653e724e37820bae0a104d3')
+sha256sums_aarch64=('2a2efc302fcf30c72d6b70f7df216855cc1b0618ed62c2ad8a481dfc0d7f6e79')
+sha256sums_armv7h=('a60ed4068ccced533ec124dfd4b3fec0259383f7a951fa7fd620e5e6c79d256d')
+sha256sums_x86_64=('59961845417ae938a8534172c24cedeb6464a19cfa554d9587960f70152cb42e')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s| %U| --no-sandbox %U|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"