summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..633333e93200
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lxc-ps-git
+ pkgdesc = Implementation of lxc-ps for LXC 1.x and 2.x
+ pkgver = r2.dd941f0
+ pkgrel = 1
+ url = https://github.com/2ion/lxc-ps
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = lxc
+ depends = python-psutil
+ provides = lxc-ps
+ conflicts = lxc-ps
+ source = lxc-ps-git::git+https://github.com/2ion/lxc-ps.git
+ md5sums = SKIP
+
+pkgname = lxc-ps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81272aab41f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=lxc-ps-git
+pkgver=r2.dd941f0
+pkgrel=1
+pkgdesc="Implementation of lxc-ps for LXC 1.x and 2.x"
+arch=(any)
+url="https://github.com/2ion/lxc-ps"
+license=('GPL')
+depends=(lxc python-psutil)
+makedepends=(git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('lxc-ps-git::git+https://github.com/2ion/lxc-ps.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-VCS}"
+ install -Dm755 lxc-ps "$pkgdir"/usr/bin/lxc-ps
+}