summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--build-fix.patch24
3 files changed, 37 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e67476a2b85..fef1e448623a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lxpanel-multiload-ng-plugin-gtk2
pkgdesc = Modern graphical system monitor, LxPanel plugin
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 3
url = https://udda.github.io/multiload-ng/
arch = i686
arch = x86_64
@@ -10,12 +10,15 @@ pkgbase = lxpanel-multiload-ng-plugin-gtk2
depends = gtk2>=2.20.0
depends = cairo
depends = lxpanel>=0.5.8
+ depends = multiload-ng-common
conflicts = lxpanel-multiload-ng-plugin-gtk3
conflicts = lxpanel-multiload-ng-plugin-gtk2-git
conflicts = lxpanel-multiload-ng-plugin-gtk3-git
replaces = lxpanel-multiload-ng-applet-gtk2
source = https://github.com/udda/multiload-ng/archive/v1.5.2.tar.gz
+ source = build-fix.patch
md5sums = bdb9344d696324bd4db04a8bce6d7ec0
+ md5sums = b474387e4532bdd6a639f721a51d2587
pkgname = lxpanel-multiload-ng-plugin-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index b5373dcb28a3..acb7b4bb8e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
-# Maintainer: Mario Cianciolo <mr.udda at gmail dot com>
-# Co-maintainer: Michael Kogan <michael.kogan at gmx dot net>
+# Maintainer: Michael Kogan <michael.kogan at gmx dot net>
+# Co-maintainer: Mario Cianciolo <mr.udda at gmail dot com>
# This file is automatically generated from multiload-ng source.
pkgname='lxpanel-multiload-ng-plugin-gtk2'
pkgdesc='Modern graphical system monitor, LxPanel plugin'
pkgver=1.5.2
-pkgrel=1
+pkgrel=3
makedepends=('intltool')
-depends=('gtk2>=2.20.0' 'cairo' 'lxpanel>=0.5.8')
+depends=('gtk2>=2.20.0' 'cairo' 'lxpanel>=0.5.8' 'multiload-ng-common')
conflicts=('lxpanel-multiload-ng-plugin-gtk3' 'lxpanel-multiload-ng-plugin-gtk2-git' 'lxpanel-multiload-ng-plugin-gtk3-git')
replaces=('lxpanel-multiload-ng-applet-gtk2')
-source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz")
-md5sums=('bdb9344d696324bd4db04a8bce6d7ec0')
+source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz" "build-fix.patch")
+md5sums=('bdb9344d696324bd4db04a8bce6d7ec0'
+'b474387e4532bdd6a639f721a51d2587')
arch=('i686' 'x86_64')
url='https://udda.github.io/multiload-ng/'
@@ -24,6 +25,7 @@ license=('GPL2')
build() {
cd "multiload-ng-$pkgver"
+ patch -p1 -i $srcdir/build-fix.patch
./autogen.sh
./configure --prefix=/usr --with-gtk=2.0 --without-awn --without-indicator --with-lxpanel --without-mate --without-standalone --without-systray --without-xfce4
make
@@ -32,4 +34,5 @@ build() {
package() {
cd "multiload-ng-$pkgver"
make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/usr/share/locale"
}
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..6e7f125bad49
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur a/common/multiload-config.c b/common/multiload-config.c
+--- a/common/multiload-config.c 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.c 2020-07-30 21:18:03.568945194 +0200
+@@ -26,6 +26,8 @@
+ #include "graph-data.h"
+ #include "multiload-config.h"
+
++GraphType graph_types[GRAPH_MAX];
++
+ guint multiload_config_get_num_colors(guint id)
+ {
+ g_assert_cmpuint (graph_types[id].num_colors, <=, MAX_COLORS);
+diff -Naur a/common/multiload-config.h b/common/multiload-config.h
+--- a/common/multiload-config.h 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.h 2020-07-30 21:18:21.685273529 +0200
+@@ -56,7 +56,7 @@
+
+
+ // global variable
+-GraphType graph_types[GRAPH_MAX];
++extern GraphType graph_types[GRAPH_MAX];
+
+
+ G_GNUC_INTERNAL guint