summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6504385f83fc..9c49e3be1cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = lxqt-panel-git
pkgdesc = The LXQt desktop panel
- pkgver = 1.3.0.37.g73e2f88e
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/lxqt/lxqt-panel
arch = i686
arch = x86_64
- license = GPL2
+ license = LGPL-2.1-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
- depends = alsa-lib
- depends = libpulse
- depends = lm_sensors
depends = libstatgrab
depends = libsysstat-git
depends = libxtst
- depends = solid5
- depends = menu-cache
- depends = libxcomposite
+ depends = alsa-lib
+ depends = libpulse
+ depends = layer-shell-qt
+ depends = solid
+ depends = kwindowsystem
+ depends = libdbusmenu-lxqt-git
+ depends = liblxqt-git
depends = lxqt-menu-data-git
- depends = libdbusmenu-qt5
depends = lxqt-globalkeys-git
provides = lxqt-panel
conflicts = lxqt-panel
diff --git a/PKGBUILD b/PKGBUILD
index a609a147c995..a748babaeb73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,16 @@
_pkgname=lxqt-panel
pkgname=$_pkgname-git
-pkgver=1.3.0.37.g73e2f88e
+pkgver=2.0.0
pkgrel=1
pkgdesc='The LXQt desktop panel'
arch=('i686' 'x86_64')
url='https://github.com/lxqt/lxqt-panel'
-license=('GPL2')
-depends=(
- "alsa-lib" "libpulse" "lm_sensors" "libstatgrab" "libsysstat-git" "libxtst"
- "solid5"
- "menu-cache" "libxcomposite" "lxqt-menu-data-git" "libdbusmenu-qt5"
- "lxqt-globalkeys-git"
-)
-makedepends=("git" "cmake" "qt5-tools" "lxqt-build-tools-git")
+license=("LGPL-2.1-only")
+depends=('libstatgrab' 'libsysstat-git' 'libxtst' 'alsa-lib' 'libpulse'
+ 'layer-shell-qt' 'solid' 'kwindowsystem'
+ 'libdbusmenu-lxqt-git' 'liblxqt-git' 'lxqt-menu-data-git' 'lxqt-globalkeys-git')
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+${url}.git")
@@ -24,7 +21,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {