summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d60090810e31..a77aeb1a0f44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = lxqt-sudo-git
pkgdesc = Qt front-end for sudo. Part of but not restricted to LXQt.
- pkgver = 0.9.0.6.ga2f898a
+ pkgver = 2.0.0
pkgrel = 1
- url = https://github.com/lxde/lxqt-sudo
+ url = https://lxqt-project.org
arch = i686
arch = x86_64
- license = LGPL2.1
+ license = LGPL-2.1-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-base
+ makedepends = qt6-tools
+ makedepends = lxqt-build-tools-git
depends = sudo
depends = liblxqt-git
optdepends = oxygen-icons: fallback icon theme on systems without LXQt
provides = lxqt-sudo
conflicts = lxqt-sudo
- source = git+https://github.com/lxde/lxqt-sudo.git
+ source = git+https://github.com/lxqt/lxqt-sudo.git
sha256sums = SKIP
pkgname = lxqt-sudo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1c9cc06e3ad6..140ca70c4674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
_pkgname=lxqt-sudo
pkgname=$_pkgname-git
-pkgver=0.9.0.6.ga2f898a
+pkgver=2.0.0
pkgrel=1
pkgdesc="Qt front-end for sudo. Part of but not restricted to LXQt."
arch=("i686" "x86_64")
-url="https://github.com/lxde/lxqt-sudo"
-license=("LGPL2.1")
-depends=("qt5-base" "sudo" "liblxqt-git")
-optdepends=("oxygen-icons: fallback icon theme on systems without LXQt")
-makedepends=("git" "cmake" "qt5-tools")
+url="https://lxqt-project.org"
+license=('LGPL-2.1-only')
+depends=('sudo' 'liblxqt-git')
+optdepends=('oxygen-icons: fallback icon theme on systems without LXQt')
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/lxde/$_pkgname.git")
+source=("git+https://github.com/lxqt/$_pkgname.git")
sha256sums=("SKIP")
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {