summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d60090810e31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lxqt-sudo-git
+ pkgdesc = Qt front-end for sudo. Part of but not restricted to LXQt.
+ pkgver = 0.9.0.6.ga2f898a
+ pkgrel = 1
+ url = https://github.com/lxde/lxqt-sudo
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = sudo
+ depends = liblxqt-git
+ optdepends = oxygen-icons: fallback icon theme on systems without LXQt
+ provides = lxqt-sudo
+ conflicts = lxqt-sudo
+ source = git+https://github.com/lxde/lxqt-sudo.git
+ sha256sums = SKIP
+
+pkgname = lxqt-sudo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c9cc06e3ad6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=lxqt-sudo
+pkgname=$_pkgname-git
+pkgver=0.9.0.6.ga2f898a
+pkgrel=1
+pkgdesc="Qt front-end for sudo. Part of but not restricted to LXQt."
+arch=("i686" "x86_64")
+url="https://github.com/lxde/lxqt-sudo"
+license=("LGPL2.1")
+depends=("qt5-base" "sudo" "liblxqt-git")
+optdepends=("oxygen-icons: fallback icon theme on systems without LXQt")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}