summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 764141f9412f..3f104fefac83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lycklig-git
pkgdesc = Image processing for lucky imaging.
- pkgver = 20150207
+ pkgver = 20180813
pkgrel = 1
- url = https://gitorious.org/adv/lycklig
+ url = https://github.com/AD-Vega/lycklig.git
arch = i686
arch = x86_64
license = GPL3
@@ -11,8 +11,7 @@ pkgbase = lycklig-git
makedepends = boost
makedepends = tclap
depends = opencv
- depends = python3-wand
- depends = python-pyqt4
+ depends = python-pyqt5
depends = python-scipy
provides = lycklig
conflicts = lycklig
diff --git a/PKGBUILD b/PKGBUILD
index 317060eb169b..f67c46801866 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jure Varlec <jure.varlec@ad-vega.si>
_pkgname=lycklig
pkgname=lycklig-git
-pkgver=20150207
+pkgver=20180813
pkgrel=1
pkgdesc="Image processing for lucky imaging."
arch=( i686 x86_64 )
-url="https://gitorious.org/adv/${_pkgname}"
+url="https://github.com/AD-Vega/${_pkgname}.git"
license=('GPL3')
-depends=( opencv python3-wand python-pyqt4 python-scipy )
+depends=( opencv python-pyqt5 python-scipy )
makedepends=( git cmake boost tclap )
checkdepends=()
optdepends=()
@@ -22,7 +22,7 @@ source=()
noextract=()
md5sums=() #generate with 'makepkg -g'
-_gitroot="git://gitorious.org/adv/${_pkgname}.git"
+_gitroot="${url}"
_gitname="master"
build() {
@@ -33,7 +33,7 @@ build() {
cd $_gitname && git pull --rebase origin
msg "The local files are updated."
else
- git clone $_gitroot $_gitname
+ git clone --depth=1 $_gitroot $_gitname
cd $_gitname
git checkout $_gitname
cd -