summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD13
2 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 603144020950..cbeb231f2476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,28 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 15:29:18 UTC 2016
pkgbase = lylibrary
pkgdesc = LyLibrary provides everything necessary to the books cataloguing, the loans management and the registration of the library readers.
- pkgver = 2.1.1
+ pkgver = 3.0
pkgrel = 1
url = http://www.codelinsoft.it/sito/2013-11-17-17-56-34/lylibrary.html#
arch = i686
arch = x86_64
license = LGPL
- depends = qt4
+ depends = qt5-base
+ depends = qt5-connectivity
+ depends = qt5-declarative
+ depends = qt5-graphicaleffects
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-translations
+ depends = qt5-webkit
+ depends = qt5-websockets
+ depends = qt5-x11extras
+ depends = qt5-xmlpatterns
depends = mysql
- depends = qca-ossl
- source = http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-sorgentesource.raw
- md5sums = 4d6663c7e675b282219673565f290ce3
+ source = http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-3-0targz.raw
+ md5sums = 8b67a73af48e515d3d1af5b2c4d83d46
pkgname = lylibrary
diff --git a/PKGBUILD b/PKGBUILD
index 9240a8885a0d..01128dc0da88 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Contributor: Calogero e Angelo ScarnĂ  <info@codelinsoft.it>
pkgname=lylibrary
-pkgver=2.1.1
+pkgver=3.0
pkgrel=1
pkgdesc="LyLibrary provides everything necessary to the books cataloguing, the loans management and the registration of the library readers."
url="http://www.codelinsoft.it/sito/2013-11-17-17-56-34/lylibrary.html#"
arch=('i686' 'x86_64')
-depends=('qt4' 'mysql' 'qca-ossl')
+depends=('qt5-base' 'qt5-connectivity' 'qt5-declarative' 'qt5-graphicaleffects' 'qt5-multimedia' 'qt5-svg' 'qt5-tools' 'qt5-translations' 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-xmlpatterns' 'mysql' )
license=(LGPL)
-source=(http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-sorgentesource.raw)
-md5sums=("4d6663c7e675b282219673565f290ce3")
+source=(http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-3-0targz.raw)
+md5sums=("8b67a73af48e515d3d1af5b2c4d83d46")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-qmake-qt4
+cmake -DCMAKE_INSTALL_PREFIX=/opt -DWANT_QT5=ON
make -j5
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
+make DESTDIR=$pkgdir install
install -d "$pkgdir"/opt
install -dm 755 ${pkgdir}/opt/lylibrary
cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/lylibrary" "${pkgdir}/opt/lylibrary"
cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/images/logo4.png" "${pkgdir}/opt/lylibrary/"
install -m 755 -d "${pkgdir}/opt/lylibrary/plugin"
-install -m 755 -d "${pkgdir}/opt/lylibrary/data"
-cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/data/" "${pkgdir}/opt/lylibrary/"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/lylibrary/desktop/lylibrary.desktop" "${pkgdir}/usr/share/applications/lylibrary.desktop"