summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0da22f563a9a..848304bed436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lynx-git
pkgdesc = The text web browser
- pkgver = 2.9.0dev.4h.r0.g05a10ac7
+ pkgver = 2.9.0dev.10k.r714.g09edd94f
pkgrel = 1
url = https://lynx.invisible-island.net/lynx.html
arch = i686
@@ -8,13 +8,13 @@ pkgbase = lynx-git
license = GPL
makedepends = git
depends = glibc
- depends = libidn
+ depends = libidn2
+ depends = ncurses
depends = openssl
- provides = lynx
+ provides = lynx=2.9.0dev.10k.r714.g09edd94f
conflicts = lynx
backup = etc/lynx.cfg
source = git+https://github.com/ThomasDickey/lynx-snapshots.git
sha256sums = SKIP
pkgname = lynx-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e4868495bd6b..1e59bd89c442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=lynx-git
-pkgver=2.9.0dev.4h.r0.g05a10ac7
+pkgver=2.9.0dev.10k.r714.g09edd94f
pkgrel=1
pkgdesc="The text web browser"
arch=('i686' 'x86_64')
url="https://lynx.invisible-island.net/lynx.html"
license=('GPL')
-depends=('glibc' 'libidn' 'openssl')
+depends=('glibc' 'libidn2' 'ncurses' 'openssl')
makedepends=('git')
-provides=('lynx')
+provides=("lynx=$pkgver")
conflicts=('lynx')
backup=('etc/lynx.cfg')
source=("git+https://github.com/ThomasDickey/lynx-snapshots.git")
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "lynx-snapshots"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+ _tag=$(git tag -l --sort -creatordate | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/[-_]/./g'
}
build() {