summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9898575c781c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = m4acut
+ pkgdesc = Losslessly & gaplessly cut m4a (AAC in MP4) files.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/nu774/m4acut
+ arch = x86_64
+ arch = i686
+ license = ZLIB
+ license = BSD
+ depends = l-smash
+ source = https://github.com/nu774/m4acut/archive/v0.1.2.tar.gz
+ sha256sums = 16e4637d278113afd99823c9b34cc62263a7b008c3cd9ef934fc09672de03439
+
+pkgname = m4acut
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9e7cf9555c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: kevku <kevku@gmx.com>
+pkgname=m4acut
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Losslessly & gaplessly cut m4a (AAC in MP4) files."
+arch=("x86_64" "i686")
+url="https://github.com/nu774/m4acut"
+license=("ZLIB" "BSD")
+depends=("l-smash")
+source=("https://github.com/nu774/m4acut/archive/v$pkgver.tar.gz")
+sha256sums=("16e4637d278113afd99823c9b34cc62263a7b008c3cd9ef934fc09672de03439")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ autoreconf -i
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}