summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--030-m64p-fix-default-config-paths.patch25
-rw-r--r--PKGBUILD7
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c9dad926f7f..2b3ccdb68ab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
- pkgver = 20201012
+ pkgver = 20201017
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -27,13 +27,15 @@ pkgbase = m64p
conflicts = mupen64plus-gui
conflicts = mupen64plus-video-gliden64
conflicts = mupen64plus
- source = git+https://github.com/loganmc10/m64p.git#commit=41e17c6616660687e95833f66ac1b6b24f89abcc
+ source = git+https://github.com/loganmc10/m64p.git#commit=e6180a8e0766707df29d94b4ad59a039a48b0dd2
source = 010-m64p-remove-build-jobs-limitation.patch
source = 020-m64p-enable-optimizations.patch
+ source = 030-m64p-fix-default-config-paths.patch
source = m64p.desktop
sha256sums = SKIP
sha256sums = 28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04
sha256sums = d3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3
+ sha256sums = ce455d2bf39dd958e76ca6342820293895bab7376988fdb27537408057c36176
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p
diff --git a/030-m64p-fix-default-config-paths.patch b/030-m64p-fix-default-config-paths.patch
new file mode 100644
index 000000000000..7e645ef25b9a
--- /dev/null
+++ b/030-m64p-fix-default-config-paths.patch
@@ -0,0 +1,25 @@
+--- a/mupen64plus-gui/mainwindow.cpp
++++ b/mupen64plus-gui/mainwindow.cpp
+@@ -4,6 +4,7 @@
+ #include <QCloseEvent>
+ #include <QActionGroup>
+ #include <QDesktopServices>
++#include <QStandardPaths>
+ #include "settingsdialog.h"
+ #include "plugindialog.h"
+ #include "mainwindow.h"
+@@ -408,11 +409,11 @@ MainWindow::MainWindow(QWidget *parent) :
+ updatePIF(ui);
+
+ if (!settings->contains("coreLibPath"))
+- settings->setValue("coreLibPath", "$APP_PATH$");
++ settings->setValue("coreLibPath", "/usr/lib");
+ if (!settings->contains("pluginDirPath"))
+- settings->setValue("pluginDirPath", "$APP_PATH$");
++ settings->setValue("pluginDirPath", "/usr/lib/mupen64plus");
+ if (!settings->contains("configDirPath"))
+- settings->setValue("configDirPath", "$CONFIG_PATH$");
++ settings->setValue("configDirPath", QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/mupen64plus");
+
+ updatePlugins();
+
diff --git a/PKGBUILD b/PKGBUILD
index 70cc7146ba29..706eaf3ae42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201012
+pkgver=20201017
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -13,20 +13,23 @@ optdepends=('p7zip: for 7z/zip support')
makedepends=('git' 'cmake' 'nasm' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=41e17c6616660687e95833f66ac1b6b24f89abcc
+_commit=e6180a8e0766707df29d94b4ad59a039a48b0dd2
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
+ '030-m64p-fix-default-config-paths.patch'
'm64p.desktop')
sha256sums=('SKIP'
'28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04'
'd3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3'
+ 'ce455d2bf39dd958e76ca6342820293895bab7376988fdb27537408057c36176'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
icotool -x m64p/mupen64plus-gui/mupen64plus.ico -o m64p/mupen64plus-gui
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-enable-optimizations.patch"
+ patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-default-config-paths.patch"
}
build() {