summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--030-m64p-fix-default-config-paths.patch2
-rw-r--r--040-m64p-add-pie.patch11
-rw-r--r--PKGBUILD9
4 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b3ccdb68ab3..2e395b338f25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
- pkgver = 20201017
+ pkgver = 20201018
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -27,15 +27,17 @@ pkgbase = m64p
conflicts = mupen64plus-gui
conflicts = mupen64plus-video-gliden64
conflicts = mupen64plus
- source = git+https://github.com/loganmc10/m64p.git#commit=e6180a8e0766707df29d94b4ad59a039a48b0dd2
+ source = git+https://github.com/loganmc10/m64p.git#commit=c4a279bf61163d984fc3bf69cacadf060f780874
source = 010-m64p-remove-build-jobs-limitation.patch
source = 020-m64p-enable-optimizations.patch
source = 030-m64p-fix-default-config-paths.patch
+ source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
sha256sums = 28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04
sha256sums = d3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3
- sha256sums = ce455d2bf39dd958e76ca6342820293895bab7376988fdb27537408057c36176
+ sha256sums = c3f932cfe90909bd2f69a352add4acdd4d67d1fb73559d651de3cec3acdc3737
+ sha256sums = 06915a74819512b423ce9c8b3717ce4132836d3b691500f0298810b92ba7ac2c
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p
diff --git a/030-m64p-fix-default-config-paths.patch b/030-m64p-fix-default-config-paths.patch
index 7e645ef25b9a..1c32a2f7b4af 100644
--- a/030-m64p-fix-default-config-paths.patch
+++ b/030-m64p-fix-default-config-paths.patch
@@ -8,7 +8,7 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
-@@ -408,11 +409,11 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -406,11 +407,11 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("coreLibPath"))
diff --git a/040-m64p-add-pie.patch b/040-m64p-add-pie.patch
new file mode 100644
index 000000000000..16aa3626d2e8
--- /dev/null
+++ b/040-m64p-add-pie.patch
@@ -0,0 +1,11 @@
+--- a/mupen64plus-gui/mupen64plus-gui.pro
++++ b/mupen64plus-gui/mupen64plus-gui.pro
+@@ -89,8 +89,6 @@ FORMS += mainwindow.ui
+
+ QMAKE_INCDIR += api interface
+
+-QMAKE_LFLAGS += -no-pie
+-
+ CONFIG += optimize_full
+
+ QMAKE_PROJECT_DEPTH = 0
diff --git a/PKGBUILD b/PKGBUILD
index 706eaf3ae42e..73831711dfa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201017
+pkgver=20201018
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -13,16 +13,18 @@ optdepends=('p7zip: for 7z/zip support')
makedepends=('git' 'cmake' 'nasm' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=e6180a8e0766707df29d94b4ad59a039a48b0dd2
+_commit=c4a279bf61163d984fc3bf69cacadf060f780874
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
'030-m64p-fix-default-config-paths.patch'
+ '040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
'28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04'
'd3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3'
- 'ce455d2bf39dd958e76ca6342820293895bab7376988fdb27537408057c36176'
+ 'c3f932cfe90909bd2f69a352add4acdd4d67d1fb73559d651de3cec3acdc3737'
+ '06915a74819512b423ce9c8b3717ce4132836d3b691500f0298810b92ba7ac2c'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
@@ -30,6 +32,7 @@ prepare() {
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-enable-optimizations.patch"
patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-default-config-paths.patch"
+ patch -d m64p -Np1 -i "${srcdir}/040-m64p-add-pie.patch"
}
build() {