summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--fix_core_dump_by_int_cast.patch26
3 files changed, 45 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51de265a7468..1fd4a7f0720c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = m64py
pkgdesc = A Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator
pkgver = 0.2.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mupen64plus/mupen64plus-ui-python
arch = any
license = GPL
@@ -12,7 +12,8 @@ pkgbase = m64py
depends = python-pyqt5
depends = python-pysdl2
source = https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/0.2.5/m64py-0.2.5.tar.gz
+ source = fix_core_dump_by_int_cast.patch
sha256sums = 0223569ec031b6e6c1d96ac51a19b9262cccce7705c84b5ca5044c94afb75fca
+ sha256sums = 598672aa8f821a9b28cdeae8a8058661e379460d9f1201104146623dc59ba7c1
pkgname = m64py
-
diff --git a/PKGBUILD b/PKGBUILD
index 196d0efdd7a3..3f824a93b979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,28 @@
pkgname=m64py
pkgver=0.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="A Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator"
arch=("any")
url="https://github.com/mupen64plus/mupen64plus-ui-python"
license=("GPL")
depends=("desktop-file-utils" "libxkbcommon-x11" "mupen64plus" "python-pyqt5" "python-pysdl2")
makedepends=("python-distribute")
-source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=("0223569ec031b6e6c1d96ac51a19b9262cccce7705c84b5ca5044c94afb75fca")
+source=(
+ "https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "fix_core_dump_by_int_cast.patch"
+)
+sha256sums=(
+ "0223569ec031b6e6c1d96ac51a19b9262cccce7705c84b5ca5044c94afb75fca"
+ "598672aa8f821a9b28cdeae8a8058661e379460d9f1201104146623dc59ba7c1"
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # https://github.com/mupen64plus/mupen64plus-ui-python/issues/191
+ patch -Np1 -i "${srcdir}/fix_core_dump_by_int_cast.patch"
+}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/fix_core_dump_by_int_cast.patch b/fix_core_dump_by_int_cast.patch
new file mode 100644
index 000000000000..9d30cbd45640
--- /dev/null
+++ b/fix_core_dump_by_int_cast.patch
@@ -0,0 +1,26 @@
+diff --git a/src/m64py/frontend/mainwindow.py b/src/m64py/frontend/mainwindow.py
+index f845bbc..7c59ff4 100644
+--- a/src/m64py/frontend/mainwindow.py
++++ b/src/m64py/frontend/mainwindow.py
+@@ -177,7 +177,7 @@ class MainWindow(QMainWindow, Ui_MainWindow):
+ width, height = size.width(), size.height()
+ dwidth, dheight = desktop.width(), desktop.height()
+ cw, ch = (dwidth/2)-(width/2), (dheight/2)-(height/2)
+- self.move(cw, ch)
++ self.move(int(cw), int(ch))
+
+ def connect_signals(self):
+ """Connects signals."""
+diff --git a/src/m64py/frontend/romreader.py b/src/m64py/frontend/romreader.py
+index ff861d0..84de37a 100644
+--- a/src/m64py/frontend/romreader.py
++++ b/src/m64py/frontend/romreader.py
+@@ -123,7 +123,7 @@ class ROMReader(QThread):
+ log.warn(str(err))
+ continue
+ percent = float(filenum) / float(num_files) * 100
+- self.parent.progressBar.valueChanged.emit(percent)
++ self.parent.progressBar.valueChanged.emit(int(percent))
+ self.exit()
+
+ def stop(self):