summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD27
-rw-r--r--mableandthewood3
-rw-r--r--mableandthewood.desktop11
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33c80b07822f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mableandthewood-gog
+ pkgdesc = Mable & The Wood (GOG version)
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://mableandthewood.com
+ arch = x86_64
+ license = custom:commercial
+ depends = openssl-1.0
+ depends = libcurl-gnutls
+ depends = glu
+ depends = libxxf86vm
+ depends = libxrandr
+ depends = libglvnd
+ depends = libx11
+ depends = libxext
+ provides = mableandthewood
+ conflicts = mableandthewood
+ source = mableandthewood.desktop
+ source = mableandthewood
+ source = file://mable_the_wood_1_7_37606.sh
+ b2sums = c9974b0fd1b47ef7ff5c327260592cc3a993cd230a1fef5347c822dad185e084bf845140f40e994cebf445dab9616f7744f89a41ea8a5a80a2a96a4c026c4730
+ b2sums = 6d67c0e4e2c1c0ef4dd27c02b8650301923df7e48536cf82d9cd9467e514a63f311e1b9ff0d1251eac3f2c18dfec3ce6970c28987689c60ca0948e9298d1ab79
+ b2sums = a0dc419c07d6a9cf909799550a656e8824a04288733f2450c2f56be5005b2d1c7579c30f246653fa8106e4a5a713c4c6e81b96d192a93be521841abf594c2fdc
+
+pkgname = mableandthewood-gog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bf3cd9bbef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
+pkgname=mableandthewood-gog
+pkgver=1.7
+pkgrel=1
+pkgdesc='Mable & The Wood (GOG version)'
+arch=(x86_64)
+url=https://mableandthewood.com
+license=(custom:commercial)
+provides=("${pkgname%-gog}")
+conflicts=("${pkgname%-gog}")
+depends=(openssl-1.0 libcurl-gnutls glu libxxf86vm libxrandr libglvnd libx11 libxext)
+source=("${pkgname%-gog}.desktop" "${pkgname%-gog}" file://mable_the_wood_1_7_37606.sh)
+b2sums=('c9974b0fd1b47ef7ff5c327260592cc3a993cd230a1fef5347c822dad185e084bf845140f40e994cebf445dab9616f7744f89a41ea8a5a80a2a96a4c026c4730'
+ '6d67c0e4e2c1c0ef4dd27c02b8650301923df7e48536cf82d9cd9467e514a63f311e1b9ff0d1251eac3f2c18dfec3ce6970c28987689c60ca0948e9298d1ab79'
+ 'a0dc419c07d6a9cf909799550a656e8824a04288733f2450c2f56be5005b2d1c7579c30f246653fa8106e4a5a713c4c6e81b96d192a93be521841abf594c2fdc')
+
+package() {
+ install -Dm755 -t "$pkgdir/opt/${pkgname%-gog}" data/noarch/game/Mable_PC
+ install -Dm644 -t "$pkgdir/opt/${pkgname%-gog}/assets" data/noarch/game/assets/{game.unx,options.ini}
+
+ install -Dm755 -t "$pkgdir/usr/bin/" "${pkgname%-gog}.sh"
+
+ install -Dm644 -t "$pkgdir/usr/share/applications" "${pkgname%-gog}.desktop"
+ install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/${pkgname%-gog}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/mableandthewood b/mableandthewood
new file mode 100644
index 000000000000..8f5621f27a97
--- /dev/null
+++ b/mableandthewood
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd "/opt/mableandthewood"
+exec "./Mable_PC" "$@"
diff --git a/mableandthewood.desktop b/mableandthewood.desktop
new file mode 100644
index 000000000000..473945508d07
--- /dev/null
+++ b/mableandthewood.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Mable & The Wood
+GenericName=Mable & The Wood
+Comment=Mable & The Wood
+Icon=mableandthewood
+Exec="Mable_PC" ""
+Categories=Game;
+Path=/opt/mableandthewood