summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--mackup.patch23
2 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5da56ca8ae21..3f4bc07172ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mackup
pkgver=0.8.15
-pkgrel=4
+pkgrel=5
pkgdesc="a small Python utitlity to keep your application settings in sync."
arch=('any')
url="https://github.com/lra/mackup"
@@ -17,7 +17,7 @@ makedepends=(
source=("https://github.com/lra/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.patch")
sha256sums=('52eb2c8be8f3c615c6c158aa4e042db5172dec379f88b8108c5f4959f80ff0da'
- '752a2dbd06fb212f8632cc2ddbcc7e3d90c733093ad8a0f4c9615dc9b3926650')
+ 'ff7ccb9ce630718a4257743c4583cba46fe0864cdddbf3ac3bc9a3d2f39d8331')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/mackup.patch b/mackup.patch
index c1751ce5f743..bb005618d2ca 100644
--- a/mackup.patch
+++ b/mackup.patch
@@ -1,13 +1,18 @@
-diff --git a/mackup/config.py b/mackup/config.py
-index 97f140e..81a6044 100644
---- a/mackup/config.py
-+++ b/mackup/config.py
-@@ -220,7 +220,7 @@ class Config(object):
+--- mackup-orig/mackup/config.py 2016-11-22 10:54:05.000000000 +0100
++++ mackup-0.8.15/mackup/config.py 2016-12-27 15:36:13.700938446 +0100
+@@ -219,10 +219,11 @@
+ " the 'file_system' engine is used.")
# Python 2 and python 3 byte strings are different.
- if sys.version_info[0] < 3:
+- if sys.version_info[0] < 3:
- path = str(path)
-+ path = path.encode("utf-8")
- else:
+- else:
- path = path.decode("utf-8")
-+ path = str(path)
++ if not isinstance(path, str):
++ if sys.version_info[0] < 3:
++ path = str(path)
++ else:
++ path = path.decode("utf-8")
+
+ return path
+