aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--pythia.patch47
3 files changed, 64 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36b66423e19d..7aabb84310a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 7 18:36:50 UTC 2018
+# Tue Jan 15 03:27:42 UTC 2019
pkgbase = madgraph-pythia8-interface
pkgdesc = MadGraph Pythia8 interface
pkgver = 1.0
- pkgrel = 6
+ pkgrel = 7
url = http://madgraph.hep.uiuc.edu/
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = madgraph-pythia8-interface
depends = python2
source = http://madgraph.physics.illinois.edu/Downloads/MG5aMC_PY8_interface/MG5aMC_PY8_interface_V1.0.tar.gz
source = python2.patch
- sha256sums = 86368b7021bacf955a6e44ecce6197a5269a73577e71af034abf68b2c1db1b80
+ source = pythia.patch
+ sha256sums = 5d9ee638ca3b736fb51979da7c83181dea61f0d7dc53ed0a836d3934d0d0c476
sha256sums = 632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64
+ sha256sums = 09bfa3f3335c533e9962a958409cd8e807924a5c4cc9482e5a2c09b2ff004543
pkgname = madgraph-pythia8-interface
diff --git a/PKGBUILD b/PKGBUILD
index a02d5ea7413d..083a7240b9f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=madgraph-pythia8-interface
pkgver=1.0
-pkgrel=6
+pkgrel=7
pkgdesc="MadGraph Pythia8 interface"
url="http://madgraph.hep.uiuc.edu/"
arch=('i686' 'x86_64')
@@ -13,14 +13,21 @@ depends=(
'pythia'
'python2'
)
-source=("http://madgraph.physics.illinois.edu/Downloads/MG5aMC_PY8_interface/MG5aMC_PY8_interface_V${pkgver}.tar.gz"
- "python2.patch")
-sha256sums=('86368b7021bacf955a6e44ecce6197a5269a73577e71af034abf68b2c1db1b80'
- '632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64')
+source=(
+ "http://madgraph.physics.illinois.edu/Downloads/MG5aMC_PY8_interface/MG5aMC_PY8_interface_V${pkgver}.tar.gz"
+ "python2.patch"
+ "pythia.patch"
+)
+sha256sums=('5d9ee638ca3b736fb51979da7c83181dea61f0d7dc53ed0a836d3934d0d0c476'
+ '632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64'
+ '09bfa3f3335c533e9962a958409cd8e807924a5c4cc9482e5a2c09b2ff004543')
prepare() {
msg2 "Fixing python references for python2"
patch -p 1 < python2.patch
+
+ msg2 "Fixing Pythia location"
+ patch -p 1 < pythia.patch
}
build() {
diff --git a/pythia.patch b/pythia.patch
new file mode 100644
index 000000000000..1701591cdf92
--- /dev/null
+++ b/pythia.patch
@@ -0,0 +1,47 @@
+--- a/get_pythia8_version.py
++++ b/get_pythia8_version.py
+@@ -29,14 +29,14 @@
+ version = None
+
+ def get_version_from_xml():
+- if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','xmldoc','Version.xml')):
++ if not os.path.exists(pjoin(pythia8_path,'share','pythia','xmldoc','Version.xml')):
+ print "Error in 'get_pythia8_version.py': could not get Pyhtia8 file \n '%s'\n storing the version number"% \
+- pjoin(local_path,'share','Pythia8','xmldoc','Version.xml')
++ pjoin(local_path,'share','pythia','xmldoc','Version.xml')
+ return None
+
+ versionfinder = re.compile('^\s*\<parmfix\s*name\=\"Pythia:versionNumber\"\s*default=\"(?P<version>[\d\.]+)\"\>')
+
+- for line in open(pjoin(pythia8_path,'share','Pythia8','xmldoc','Version.xml')):
++ for line in open(pjoin(pythia8_path,'share','pythia','xmldoc','Version.xml')):
+ match = versionfinder.match(line)
+ if match:
+ version = match.group('version')
+
+--- a/compile.py
++++ b/compile.py
+@@ -103,17 +103,17 @@
+
+ # Now proceed with the installation
+
+-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc')):
++if not os.path.exists(pjoin(pythia8_path,'share','pythia','examples','Makefile.inc')):
+ print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
+- pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc')
++ pjoin(pythia8_path,'share','pythia','examples','Makefile.inc')
+ sys.exit(error_exit_code)
+-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc'),
++shutil.copy(pjoin(pythia8_path,'share','pythia','examples','Makefile.inc'),
+ pjoin(local_path,'Makefile.inc'))
+-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile')):
++if not os.path.exists(pjoin(pythia8_path,'share','pythia','examples','Makefile')):
+ print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
+- pjoin(pythia8_path,'share','Pythia8','examples','Makefile')
++ pjoin(pythia8_path,'share','pythia','examples','Makefile')
+ sys.exit(error_exit_code)
+-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile'),
++shutil.copy(pjoin(pythia8_path,'share','pythia','examples','Makefile'),
+ pjoin(local_path,'Makefile'))
+
+ if _use_original_PY8_makefile: