aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--pythia.patch18
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2442bc808582..010f94af8d1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = madgraph-pythia8-interface
pkgdesc = MadGraph Pythia8 interface
pkgver = 1.0
- pkgrel = 7
+ pkgrel = 8
url = http://madgraph.hep.uiuc.edu/
arch = i686
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = madgraph-pythia8-interface
source = pythia.patch
sha256sums = 6467dcc5539796f8fd81b9a74288bf8e9b33378bb0507b2771d5c86696c7a32e
sha256sums = 632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64
- sha256sums = 09bfa3f3335c533e9962a958409cd8e807924a5c4cc9482e5a2c09b2ff004543
+ sha256sums = e506dad2224ed639a83537b21eadeda0ee244e9b5d5ee2770e536564f1e41491
pkgname = madgraph-pythia8-interface
diff --git a/PKGBUILD b/PKGBUILD
index 2bfd07c3e848..e022fe197096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=madgraph-pythia8-interface
pkgver=1.0
-pkgrel=7
+pkgrel=8
pkgdesc="MadGraph Pythia8 interface"
url="http://madgraph.hep.uiuc.edu/"
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ source=(
)
sha256sums=('6467dcc5539796f8fd81b9a74288bf8e9b33378bb0507b2771d5c86696c7a32e'
'632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64'
- '09bfa3f3335c533e9962a958409cd8e807924a5c4cc9482e5a2c09b2ff004543')
+ 'e506dad2224ed639a83537b21eadeda0ee244e9b5d5ee2770e536564f1e41491')
prepare() {
msg2 "Fixing python references for python2"
diff --git a/pythia.patch b/pythia.patch
index 1701591cdf92..7604319a7ce6 100644
--- a/pythia.patch
+++ b/pythia.patch
@@ -5,16 +5,16 @@
def get_version_from_xml():
- if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','xmldoc','Version.xml')):
-+ if not os.path.exists(pjoin(pythia8_path,'share','pythia','xmldoc','Version.xml')):
++ if not os.path.exists(pjoin(pythia8_path,'share','pythia8','xmldoc','Version.xml')):
print "Error in 'get_pythia8_version.py': could not get Pyhtia8 file \n '%s'\n storing the version number"% \
- pjoin(local_path,'share','Pythia8','xmldoc','Version.xml')
-+ pjoin(local_path,'share','pythia','xmldoc','Version.xml')
++ pjoin(local_path,'share','pythia8','xmldoc','Version.xml')
return None
versionfinder = re.compile('^\s*\<parmfix\s*name\=\"Pythia:versionNumber\"\s*default=\"(?P<version>[\d\.]+)\"\>')
- for line in open(pjoin(pythia8_path,'share','Pythia8','xmldoc','Version.xml')):
-+ for line in open(pjoin(pythia8_path,'share','pythia','xmldoc','Version.xml')):
++ for line in open(pjoin(pythia8_path,'share','pythia8','xmldoc','Version.xml')):
match = versionfinder.match(line)
if match:
version = match.group('version')
@@ -26,22 +26,22 @@
# Now proceed with the installation
-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc')):
-+if not os.path.exists(pjoin(pythia8_path,'share','pythia','examples','Makefile.inc')):
++if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc')):
print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
- pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc')
-+ pjoin(pythia8_path,'share','pythia','examples','Makefile.inc')
++ pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc')
sys.exit(error_exit_code)
-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc'),
-+shutil.copy(pjoin(pythia8_path,'share','pythia','examples','Makefile.inc'),
++shutil.copy(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc'),
pjoin(local_path,'Makefile.inc'))
-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile')):
-+if not os.path.exists(pjoin(pythia8_path,'share','pythia','examples','Makefile')):
++if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile')):
print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
- pjoin(pythia8_path,'share','Pythia8','examples','Makefile')
-+ pjoin(pythia8_path,'share','pythia','examples','Makefile')
++ pjoin(pythia8_path,'share','pythia8','examples','Makefile')
sys.exit(error_exit_code)
-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile'),
-+shutil.copy(pjoin(pythia8_path,'share','pythia','examples','Makefile'),
++shutil.copy(pjoin(pythia8_path,'share','pythia8','examples','Makefile'),
pjoin(local_path,'Makefile'))
if _use_original_PY8_makefile: