summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--magic-devel.changelog15
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..221d6a04590d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = magic-devel
+ pkgdesc = A VLSI layout system
+ pkgver = 8.0.157
+ pkgrel = 1
+ url = http://opencircuitdesign.com/magic/
+ changelog = magic-devel.changelog
+ arch = i686
+ arch = x86_64
+ license = custom:copyright
+ makedepends = tcsh
+ depends = tcl
+ depends = tk
+ depends = libx11
+ optdepends = mesa: for better graphics
+ optdepends = blt: to create a tree diagram of the cell hierarchy in a design
+ provides = magic
+ conflicts = magic
+ source = http://opencircuitdesign.com/magic/archive/magic-8.0.157.tgz
+ md5sums = c8139e42cd73258ed2575ddc2ca99641
+
+pkgname = magic-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e8e347a8abe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jared Casper <jaredcasper@gmail.com>
+pkgname=magic-devel
+pkgver=8.0.157
+pkgrel=1
+pkgdesc="A VLSI layout system"
+url="http://opencircuitdesign.com/magic/"
+arch=('i686' 'x86_64')
+license=('custom:copyright')
+depends=('tcl' 'tk' 'libx11')
+makedepends=('tcsh')
+optdepends=('mesa: for better graphics'
+ 'blt: to create a tree diagram of the cell hierarchy in a design')
+conflicts=('magic')
+provides=('magic')
+changelog=$pkgname.changelog
+source=(http://opencircuitdesign.com/magic/archive/magic-$pkgver.tgz)
+md5sums=('c8139e42cd73258ed2575ddc2ca99641')
+
+build () {
+ cd "$srcdir/magic-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/magic-$pkgver"
+ make -j1 DESTDIR="$pkgdir" MANDIR=/usr/share/man install
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ if [ -x /usr/bin/ps2ascii ]; then
+ /usr/bin/ps2ascii "$pkgdir/usr/lib/magic/doc/copyright.ps" > "$pkgdir/usr/share/licenses/$pkgname/copyright"
+ else
+ install -m644 "$pkgdir/usr/lib/magic/doc/copyright.ps" "$pkgdir/usr/share/licenses/magic"
+ fi
+}
diff --git a/magic-devel.changelog b/magic-devel.changelog
new file mode 100644
index 000000000000..b5abfc125706
--- /dev/null
+++ b/magic-devel.changelog
@@ -0,0 +1,15 @@
+2013-10-21 Kyle Keen <keenerd@gmail.com>
+ * 8.0.157
+ - Version bump
+ - quoting
+ - license var
+ - arch var
+
+2010-09-21 Jared Casper <jaredcasper@gmail.com>
+ * 7.5.207-1
+ - Version bump
+ - use changelog variable
+ - split build() and package()
+ - remove || return 1
+ - mkdir/cp -> install
+ - correct man directory