summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--minizip.patch12
3 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7690d8d9763..cdc3c55a1b44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = magics++
pkgdesc = Magics is the latest generation of the ECMWF's Meteorological plotting software MAGICS.
- pkgver = 4.12.1
+ pkgver = 4.15.4
pkgrel = 1
url = https://confluence.ecmwf.int/display/MAGP
arch = i686
@@ -18,9 +18,9 @@ pkgbase = magics++
optdepends = ksh
optdepends = libaec
optdepends = odb_api
- source = http://confluence.ecmwf.int/download/attachments/3473464/Magics-4.12.1-Source.tar.gz
- source = gcc11.patch
- sha256sums = c9e2322e3ee9e0e1882f1c7f728751ba81a7207a6d4732d39b3dd97175fa8007
- sha256sums = c0250ac473b4703e79c8f879f6271d1409e800a0f8a7a77b3793cc9ce9a85951
+ source = http://confluence.ecmwf.int/download/attachments/3473464/Magics-4.15.4-Source.tar.gz
+ source = minizip.patch
+ sha256sums = a38033aa8bd5845c55ad10f9bf5aaee932177e3aa88cf8f174814d825d354285
+ sha256sums = f09ee5f328edd326d94e0bf5a751351956455de1816ce7ff93368eae6b6835d4
pkgname = magics++
diff --git a/PKGBUILD b/PKGBUILD
index 931368e13c53..c1d196584205 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=magics++
Pkgname=Magics
-pkgver=4.12.1
+pkgver=4.15.4
_attnum=3473464
pkgrel=1
pkgdesc="Magics is the latest generation of the ECMWF's Meteorological plotting software MAGICS."
@@ -15,14 +15,12 @@ license=('Apache')
depends=('eccodes>=2.19.0' libgeotiff qt6-base pango python)
optdepends=(ksh libaec odb_api)
makedepends=(cmake gcc-fortran python-jinja swig)
-source=(http://confluence.ecmwf.int/download/attachments/${_attnum}/${Pkgname}-${pkgver}-Source.tar.gz
- gcc11.patch)
-sha256sums=('c9e2322e3ee9e0e1882f1c7f728751ba81a7207a6d4732d39b3dd97175fa8007'
- 'c0250ac473b4703e79c8f879f6271d1409e800a0f8a7a77b3793cc9ce9a85951')
+source=(http://confluence.ecmwf.int/download/attachments/${_attnum}/${Pkgname}-${pkgver}-Source.tar.gz minizip.patch)
+sha256sums=('a38033aa8bd5845c55ad10f9bf5aaee932177e3aa88cf8f174814d825d354285' 'f09ee5f328edd326d94e0bf5a751351956455de1816ce7ff93368eae6b6835d4')
prepare() {
cd "${Pkgname}-${pkgver}-Source"
- patch --forward --strip=1 --input=$srcdir/gcc11.patch
+ patch --forward --strip=1 --input=$srcdir/minizip.patch
}
build() {
diff --git a/minizip.patch b/minizip.patch
new file mode 100644
index 000000000000..d2d0ab226767
--- /dev/null
+++ b/minizip.patch
@@ -0,0 +1,12 @@
+diff -u -r Magics-4.15.4-Source-orig/src/drivers/minizip/zip.c Magics-4.15.4-Source/src/drivers/minizip/zip.c
+--- Magics-4.15.4-Source-orig/src/drivers/minizip/zip.c 2024-06-10 00:18:59.230647546 +0200
++++ Magics-4.15.4-Source/src/drivers/minizip/zip.c 2024-06-10 00:21:25.796509940 +0200
+@@ -880,7 +880,7 @@
+ unsigned char bufHead[RAND_HEAD_LEN];
+ unsigned int sizeHead;
+ zi->ci.encrypt = 1;
+- zi->ci.pcrc_32_tab = get_crc_table();
++ zi->ci.pcrc_32_tab = (const long unsigned int *)(get_crc_table());
+ /*init_keys(password,zi->ci.keys,zi->ci.pcrc_32_tab);*/
+
+ sizeHead=crypthead(password,bufHead,RAND_HEAD_LEN,zi->ci.keys,zi->ci.pcrc_32_tab,crcForCrypting);