summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--patch11
3 files changed, 8 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df0c96f94662..eef24c9786c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = magics++
pkgdesc = Magics is the latest generation of the ECMWF's Meteorological plotting software MAGICS.
- pkgver = 4.1.3
- pkgrel = 2
+ pkgver = 4.2.0
+ pkgrel = 1
url = https://software.ecmwf.int/wiki/display/MAGP
arch = i686
arch = x86_64
@@ -24,10 +24,8 @@ pkgbase = magics++
depends = libgeotiff
optdepends = libaec
optdepends = odb_api
- source = http://software.ecmwf.int/wiki/download/attachments/3473464/Magics-4.1.3-Source.tar.gz
- source = patch
- md5sums = d2f71e15837cd79a26288adeaf82098e
- md5sums = 73b04ae78df8c2f6e88b2a36dcd2dd96
+ source = http://software.ecmwf.int/wiki/download/attachments/3473464/Magics-4.2.0-Source.tar.gz
+ md5sums = fddb1cc7090472a702926dc8d56bcfae
pkgname = magics++
diff --git a/PKGBUILD b/PKGBUILD
index 649ecdaa1280..7fb90ee1e389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=magics++
Pkgname=Magics
-pkgver=4.1.3
+pkgver=4.2.0
_attnum=3473464
-pkgrel=2
+pkgrel=1
pkgdesc="Magics is the latest generation of the ECMWF's Meteorological plotting software MAGICS."
arch=('i686' 'x86_64')
url="https://software.ecmwf.int/wiki/display/MAGP"
@@ -13,13 +13,11 @@ license=('Apache')
depends=('qt5-base' 'proj' 'fftw' 'pango' 'netcdf-cxx-legacy' 'eccodes' 'python' 'libgeotiff')
optdepends=('libaec' 'odb_api')
makedepends=('perl-xml-parser' 'gcc-fortran' 'swig' 'python2-numpy' 'cmake' 'boost' 'emos' 'python2-jinja')
-source=(http://software.ecmwf.int/wiki/download/attachments/${_attnum}/${Pkgname}-${pkgver}-Source.tar.gz patch)
-md5sums=('d2f71e15837cd79a26288adeaf82098e'
- '73b04ae78df8c2f6e88b2a36dcd2dd96')
+source=(http://software.ecmwf.int/wiki/download/attachments/${_attnum}/${Pkgname}-${pkgver}-Source.tar.gz)
+md5sums=('fddb1cc7090472a702926dc8d56bcfae')
build() {
cd "$srcdir/${Pkgname}-${pkgver}-Source"
- patch -p0 -i ../patch
rm -fr src/boost && ln -sf /usr/include/boost src
[ -x /usr/bin/odb ] && has_odb=ON || has_odb=OFF
# force this for now. Metview does not compile
diff --git a/patch b/patch
deleted file mode 100644
index b67c8ff6dad3..000000000000
--- a/patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/ecbuild_pkgconfig.cmake.orig 2016-03-28 21:41:34.726196875 +0200
-+++ cmake/ecbuild_pkgconfig.cmake 2016-03-28 21:41:59.595426196 +0200
-@@ -190,7 +190,7 @@
- foreach( _incdir ${${INCLUDE_DIRS}} )
-
- foreach( _ignore ${ignore_include_dirs} )
-- if( "${_incdir}" MATCHES "${_ignore}" )
-+ if( "${_incdir}" EQUAL "${_ignore}" )
- unset( _incdir )
- break()
- endif()