summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
-rw-r--r--changelog.txt23
-rwxr-xr-xmigrationhelper2
4 files changed, 39 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c186fe6a7ff..a91729e374ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mailwizard-git
- pkgdesc = Configure neomutt, isync, getmail and msmtp with pass for passwords
- pkgver = r737.150b8b6
+ pkgdesc = Configure neomutt, isync, getmail and msmtp with pass for passwords (POP3/SMTP)
+ pkgver = 2.0.6.r0.g1a5962e
pkgrel = 1
url = https://github.com/rpuntaie/mailwizard
install = wizard.install
@@ -33,7 +33,6 @@ pkgbase = mailwizard-git
source = git+https://github.com/rpuntaie/mailwizard
source = migrationhelper
sha256sums = SKIP
- sha256sums = 34682620297727b9bf93670b84592050d59181e682d3867cd56aefedbd67243f
+ sha256sums = 96471dc5a53af342cf14f5ec119df81509617f960c707d732781a24d9e2ed3c6
pkgname = mailwizard-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 71b1cb626670..38d784fb4da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
# Upstream author : Roland Puntaier <roland [dot] puntaier [at] gmail [dot] com>
-# Upstream author : Luke Smith <luke [at] lukesmith [dot] xyz>
pkgname=mailwizard-git
+_name="${pkgname%-git}"
-pkgver() {
- cd "${pkgname%-git}"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-pkgver=r737.150b8b6
+pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/-/.r/;s/-/./'; }
+pkgver=2.0.6.r0.g1a5962e
pkgrel=1
-pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords'
+pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords (POP3/SMTP)'
arch=('x86_64')
-url="https://github.com/rpuntaie/${pkgname%-git}"
+url="https://github.com/rpuntaie/$_name"
license=('GPL3')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" 'mutt-wizard')
+provides=("$_name")
+conflicts=("$_name" 'mutt-wizard')
makedepends=('git')
depends=('neomutt' 'isync' 'getmail6' 'msmtp' 'notmuch-runtime' 'pass' 'urlscan')
@@ -42,19 +39,19 @@ install=wizard.install
source=("git+$url"
'migrationhelper')
sha256sums=('SKIP'
- '34682620297727b9bf93670b84592050d59181e682d3867cd56aefedbd67243f')
+ '96471dc5a53af342cf14f5ec119df81509617f960c707d732781a24d9e2ed3c6')
#check() {
-# cd "${pkgname%-git}"
+# cd "$_name"
# ./dotests
#}
package() {
- cd "${pkgname%-git}"
+ cd "$_name"
make DESTDIR="$pkgdir" -s install
- install -m755 ../migrationhelper -t"$pkgdir/usr/share/${pkgname%-git}/"
- install -Dm644 README.rst -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
+ install -m755 ../migrationhelper -t"$pkgdir/usr/share/$_name/"
+ install -Dm644 README.rst -t"$pkgdir/usr/share/doc/$_name/"
}
diff --git a/changelog.txt b/changelog.txt
index b29b9517ae52..8bea508fc1d3 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,5 +1,28 @@
History (newest first)
+20210830 v2.0.6
+
+- update share/domains.csv
+- \Cr fix to mark read
+- skip getmail oldmail- files
+- fix: {cur,new,tmp} folder created
+
+20200720 v2.0.5
+
+- in case of symlink getmail rc files, don't overwrite them.
+- export MWNOTMUCHNEW=0, to suppress notmuch call
+- if getmail rc's and mbsyncrc overlap emails, don't fetch from account twice
+- create procmail rc file template for emails and commented use in getmail rc
+- color fix
+- fix in tests
+
+20200720 v2.0.4
+
+- fix the case with getmail path for MDA_external
+- added a test script to test getmail python 3 port (getmail6).
+- improved mailbox decoding and take mailboxes as they are to avoid creating new labels on Gmail
+- handle the case when config file are broken links
+
20200317 fixed "mailboxes" line
Generate man page from readme, to avoid duplicate descriptions.
diff --git a/migrationhelper b/migrationhelper
index 1965368bfd47..20f1f80bbf94 100755
--- a/migrationhelper
+++ b/migrationhelper
@@ -53,4 +53,4 @@ case x$REPLY in
esac
printf '\033[0m\n'
-# vim: ts=2 sw=2 noet ft=bash:
+# vim: ts=2 sw=2 noet ft=sh: