summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD51
-rw-r--r--changelog.txt52
3 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0b505cde28c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = mailwizard-git
+ pkgdesc = Configure neomutt, isync, getmail and msmtp with pass for passwords
+ pkgver = r723.b52a03b
+ pkgrel = 1
+ url = https://github.com/rpuntaie/mailwizard
+ changelog = changelog.txt
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = neomutt
+ depends = isync
+ depends = getmail
+ depends = msmtp
+ depends = pass
+ depends = urlscan
+ optdepends = imagemagick: view images inside of the neomutt TUI
+ optdepends = w3m: view HTML email and images inside of the neomutt TUI
+ optdepends = lynx: view HTML email inside of the neomutt TUI
+ optdepends = links: view HTML email inside of the neomutt TUI
+ optdepends = elinks: view HTML email inside of the neomutt TUI
+ optdepends = abook: contact store and tab completion
+ optdepends = cronie: auto-sync mails - alt.: fcron
+ optdepends = fcron: auto-sync mails - alt.: cronie
+ optdepends = pam-gnupg: automatically unlock gpg keys at session login
+ provides = mailwizard
+ conflicts = mailwizard
+ conflicts = mutt-wizard
+ options = zipman
+ source = git+https://github.com/rpuntaie/mailwizard
+ sha256sums = SKIP
+
+pkgname = mailwizard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..953a96c58165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
+# Upstream author : Roland Puntaier <roland [dot] puntaier [at] gmail [dot] com>
+# Upstream author : Luke Smith <luke [at] lukesmith [dot] xyz>
+
+pkgname='mailwizard-git'
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgver=r723.b52a03b
+pkgrel=1
+
+pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords'
+arch=('any')
+url="https://github.com/rpuntaie/${pkgname%-git}"
+license=('GPL3')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'mutt-wizard')
+
+makedepends=('git')
+depends=('neomutt' 'isync' 'getmail' 'msmtp' 'pass' 'urlscan')
+optdepends=('imagemagick: view images inside of the neomutt TUI'
+ 'w3m: view HTML email and images inside of the neomutt TUI'
+ 'lynx: view HTML email inside of the neomutt TUI'
+ 'links: view HTML email inside of the neomutt TUI'
+ 'elinks: view HTML email inside of the neomutt TUI'
+ 'abook: contact store and tab completion'
+ 'cronie: auto-sync mails - alt.: fcron'
+ 'fcron: auto-sync mails - alt.: cronie'
+ 'pam-gnupg: automatically unlock gpg keys at session login')
+#checkdepends=('bash-bats')
+
+options=('zipman')
+
+changelog=changelog.txt
+source=("git+$url")
+sha256sums=('SKIP')
+
+#check() {
+# cd "${pkgname%-git}"
+# ./dotests
+#}
+
+package() {
+ cd "${pkgname%-git}"
+ make DESTDIR="$pkgdir" -s install
+ install -Dm644 -t"$pkgdir/usr/share/doc/${pkgname%-git}/" README.rst
+}
+
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..c043db74a7a6
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,52 @@
+ History (newest first)
+
+Generate man page from readme, to avoid duplicate descriptions.
+Readme in rst instead of md.
+Separate changelog.txt.
+
+Add tests and made bug fixes
+
+*urlscan* instead of *urlview*
+
+*wm* generates *mutt* config on every full sync,
+- to reflect changes in mailboxes in the shortcuts
+- to reflect changes in *mbsync/getmail* config in *mutt* config
+
+*wm* integrates *mailsync*,
+not to overload the system namespace and because of code reuse
+
+*remove|rm* instead of *delete*, *list|ls* instead of only *ls*
+
+Make channel name equal to email address
+to avoid choosing a new name for the same thing.
+
+Other more vim-like shortcut changes
+
+*gm/gM* to sync mail inside *mutt*, as *o/O* has a *mutt* assignment already.
+
+Honor *$MAILDIR*, *$XDG_CONFIG_HOME*, *$XDG_CACHE_HOME*, if defined.
+
+`isync`/`mbsync` has replaced `offlineimap` as the backend.
+Offlineimap was error-prone, bloated, used obsolete Python 2 modules and required separate steps to install the system.
+
+`mw` is now an installed program instead of just a script needed to be kept in your mutt folder.
+
+`dialog` is no longer used (less bloat) and the interface is simply text commands.
+
+More autogenerated shortcuts that allow quickly moving and copying mail between boxes.
+
+More elegant attachment handling.
+
+Image/video/pdf attachments without relying on the neomutt instance.
+
+abook integration by default.
+
+The messy template files and other directories have been moved or removed, leaving a clean config folder.
+
+msmtp configs moved to `~/.config/` and mail default location moved to `~/Mail`, reducing mess in `~`.
+
+`pass` is used as a password manager instead of separately saving passwords.
+
+Script is POSIX sh compliant.
+
+Addition of a manual `man mw`.