summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baced7fe0256..65f0ee6114d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = maint
pkgdesc = A utility to automatically perform Arch Linux system maintenance
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
url = https://gitlab.com/mgdobachesky/ArchSystemMaintenance
arch = x86_64
license = GPLv3
depends = awk
- depends = duplicity
depends = pacman-contrib
depends = pacutils
depends = python
depends = python-dateutil
depends = python-xmltodict
depends = reflector
+ depends = rsync
depends = sed
+ depends = sudo
depends = vim
backup = opt/maint/settings.sh
- source = https://gitlab.com/mgdobachesky/ArchSystemMaintenance/raw/master/pkg/maint-1.6.tar.xz
- md5sums = f3c4b1688389eefedc20cc356c8601c5
+ source = https://gitlab.com/mgdobachesky/ArchSystemMaintenance/raw/master/pkg/maint-1.7.tar.xz
+ md5sums = c6f9626703e7a15334ec0ebea649bd3d
pkgname = maint
diff --git a/PKGBUILD b/PKGBUILD
index 3f64efe24392..c42c27521be3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _install_dir="opt/$_pkg_name"
_symlink_dir="usr/bin"
pkgname="$_pkg_name"
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="A utility to automatically perform Arch Linux system maintenance"
arch=('x86_64')
@@ -13,20 +13,21 @@ url="https://gitlab.com/mgdobachesky/ArchSystemMaintenance"
license=('GPLv3')
depends=(
'awk'
- 'duplicity'
'pacman-contrib'
'pacutils'
'python'
'python-dateutil'
'python-xmltodict'
'reflector'
+ 'rsync'
'sed'
+ 'sudo'
'vim')
backup=("$_install_dir/settings.sh")
source=("https://gitlab.com/mgdobachesky/ArchSystemMaintenance/raw/master/pkg/$pkgname-$pkgver.tar.xz")
-md5sums=('f3c4b1688389eefedc20cc356c8601c5')
+md5sums=('c6f9626703e7a15334ec0ebea649bd3d')
build() {
umask 022