summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD29
-rw-r--r--makemkv-ffmpeg.patch25
3 files changed, 25 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b95e01657e35..427fb9da1468 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,28 @@
pkgbase = makemkv
- pkgdesc = DVD and Blu-ray to MKV converter and network streamer
- pkgver = 1.16.1
+ pkgdesc = DVD and Blu-ray to MKV converter
+ pkgver = 1.17.6
pkgrel = 1
url = https://www.makemkv.com
install = makemkv.install
- arch = i686
arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = custom: GuinpinSoft Inc EULA
license = LGPL
license = MPL
- license = custom
depends = qt5-base
- depends = libxkbcommon-x11
- depends = hicolor-icon-theme
- depends = icu
depends = ffmpeg
- optdepends = lib32-glibc: dts support
- optdepends = ccextractor: extract CC streams from some DVD media
- source = https://www.makemkv.com/download/makemkv-bin-1.16.1.tar.gz
- source = https://www.makemkv.com/download/makemkv-oss-1.16.1.tar.gz
+ optdepends = java-runtime
+ source = https://www.makemkv.com/download/makemkv-bin-1.17.6.tar.gz
+ source = https://www.makemkv.com/download/makemkv-oss-1.17.6.tar.gz
source = makemkv.1
source = makemkvcon.1
source = mmdtsdec.1
- sha256sums = 941f88acfb3790ecc008b2675e8ad3d0353f0163778cc1cb9507aa87c3427db6
- sha256sums = 32e0ee2708527ce22a961c7249c607d11d88f5ffdb41809a7b7ed8003af48845
+ sha256sums = 287646005029f771d366cf0e4fbeb17fcf1033452d955547deae7b0999b4ed1b
+ sha256sums = d9db4d772bf4f9061642b7eb22ee5140a48de2c71258ab8b14d949657a710d43
sha256sums = 5573b2e4bade10d8cd258a7c235eb46f66ef8c8c97e5d5eb090c38fa0f94389b
sha256sums = f12c0facf2f0071a9f728b138986f0a4c2b4ff6ace2dfb2e96364e215e9fda6f
sha256sums = 2a6237d3d5ce073734c658c7ec5d2141ecd0047e6d3c45d1bd594135c928878f
+ optdepends_x86_64 = lib32-glibc: dts support
pkgname = makemkv
-
diff --git a/PKGBUILD b/PKGBUILD
index bc94489991c3..62751f479dd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,43 @@
-# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Marcel Korpel <marcel[dot]korpel[at]gmail>
# Contributor: Olaf Bauer <hydro@freenet.de>
pkgname=makemkv
-pkgver=1.16.1
+pkgver=1.17.6
pkgrel=1
-pkgdesc="DVD and Blu-ray to MKV converter and network streamer"
-arch=('i686' 'x86_64')
+pkgdesc="DVD and Blu-ray to MKV converter"
+arch=(x86_64 i686 aarch64)
url="https://www.makemkv.com"
-license=('LGPL' 'MPL' 'custom')
-depends=('qt5-base' 'libxkbcommon-x11' 'hicolor-icon-theme' 'icu' 'ffmpeg')
-if [ "$CARCH" = "x86_64" ]; then
- optdepends=('lib32-glibc: dts support'
- 'ccextractor: extract CC streams from some DVD media')
-fi
+license=('custom: GuinpinSoft Inc EULA' LGPL MPL)
+depends=(qt5-base ffmpeg)
+optdepends=(java-runtime)
+optdepends_x86_64=('lib32-glibc: dts support')
install=makemkv.install
source=(${url}/download/${pkgname}-bin-${pkgver}.tar.gz
${url}/download/${pkgname}-oss-${pkgver}.tar.gz
makemkv.1
makemkvcon.1
mmdtsdec.1)
-sha256sums=('941f88acfb3790ecc008b2675e8ad3d0353f0163778cc1cb9507aa87c3427db6'
- '32e0ee2708527ce22a961c7249c607d11d88f5ffdb41809a7b7ed8003af48845'
+sha256sums=('287646005029f771d366cf0e4fbeb17fcf1033452d955547deae7b0999b4ed1b'
+ 'd9db4d772bf4f9061642b7eb22ee5140a48de2c71258ab8b14d949657a710d43'
'5573b2e4bade10d8cd258a7c235eb46f66ef8c8c97e5d5eb090c38fa0f94389b'
'f12c0facf2f0071a9f728b138986f0a4c2b4ff6ace2dfb2e96364e215e9fda6f'
'2a6237d3d5ce073734c658c7ec5d2141ecd0047e6d3c45d1bd594135c928878f')
build() {
cd "${srcdir}/${pkgname}-oss-${pkgver}"
- CFLAGS="$CFLAGS -std=c++11" CC=gcc CXX=g++ ./configure --prefix=/usr
+ ./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/${pkgname}-oss-${pkgver}"
- make DESTDIR=\""${pkgdir}"\" install
+ make DESTDIR="${pkgdir}" install
cd "${srcdir}/${pkgname}-bin-${pkgver}"
install -d tmp
echo accepted > tmp/eula_accepted
- make DESTDIR=\""${pkgdir}"\" install
+ make DESTDIR="${pkgdir}" install
install -Dm 644 src/eula_en_linux.txt "${pkgdir}/usr/share/licenses/${pkgname}/eula_en_linux.txt"
diff --git a/makemkv-ffmpeg.patch b/makemkv-ffmpeg.patch
deleted file mode 100644
index 83dafc1af4a3..000000000000
--- a/makemkv-ffmpeg.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Taken from https://negativo17.org/repos/multimedia/epel-7/SRPMS/makemkv-1.12.2-2.el7.src.rpm
-See https://github.com/FFmpeg/FFmpeg/commit/7c6eb0a1b7bf1aac7f033a7ec6d8cacc3b5c2615
-and https://github.com/FFmpeg/FFmpeg/commit/b79a7da36faa6bb5914b04800b548e99eb3b81ca
-diff --git a/libffabi/src/ffabi.c b/libffabi/src/ffabi.c
-index 20db4e9..f08d53c 100644
---- a/libffabi/src/ffabi.c
-+++ b/libffabi/src/ffabi.c
-@@ -517,7 +517,7 @@ FFM_AudioEncodeContext* __cdecl ffm_audio_encode_init(void* logctx,const char* n
- info->profile : FF_PROFILE_UNKNOWN;
-
- if ((CodecFlags&FFM_CODEC_FLAG_GLOBAL_HEADER)!=0)
-- ctx->avctx->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ ctx->avctx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
-
- if (argp) {
- for (i=0;argp[i];i+=2) {
-@@ -718,7 +718,7 @@ int __cdecl ffm_audio_encode_get_info(FFM_AudioEncodeContext* ctx,FFM_AudioEncod
- info->delay = (int32_t)ctx->avctx->delay;
- info->flags = 0;
-
-- if ((ctx->avctx->flags&CODEC_FLAG_GLOBAL_HEADER)!=0)
-+ if ((ctx->avctx->flags&AV_CODEC_FLAG_GLOBAL_HEADER)!=0)
- info->flags |= FFM_CODEC_FLAG_GLOBAL_HEADER;
-
- return 0;