summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
-rw-r--r--buildenv_ext.conf2
-rw-r--r--compress-param_max.conf4
-rw-r--r--graphite.sh.in2
-rw-r--r--pgo.sh.in1
-rw-r--r--rice.sh.in4
-rw-r--r--upx.sh.in17
8 files changed, 37 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 006182e7978f..f62faa251e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = makepkg-optimize
pkgdesc = Supplemental build and packaging optimizations for makepkg
- pkgver = 18
- pkgrel = 3
+ pkgver = 21
+ pkgrel = 1
url = https://wiki.archlinux.org/index.php/Makepkg-optimize
arch = any
license = GPL
@@ -10,9 +10,9 @@ pkgbase = makepkg-optimize
optdepends = optipng: Optimize PNG files
optdepends = svgo: Optimize SVG files
optdepends = openmp: Parallelize loops
+ optdepends = polly: Polyhedral model optimization for clang
backup = etc/makepkg-optimize.conf
source = pgo.sh.in
- source = ZZ-lto.sh.in
source = graphite.sh.in
source = rice.sh.in
source = upx-exec.sh.in
@@ -32,14 +32,13 @@ pkgbase = makepkg-optimize
source = pkgopts_ext.conf
source = pkgopts-param_ext.conf
source = compress-param_max.conf
- sha1sums = 2b746b2d8bf57691f1b25afce96a2752f6eee7e5
- sha1sums = 61c765080f3d41dbae15be9212667f9e6364550b
- sha1sums = d7a3801037333c582dba976db27cf8896bc1b401
- sha1sums = c99d9cb49dd31924a1cb298bcfe142cef31a9fd3
+ sha1sums = 4c5f0be71638a6ec2f18c01675d99f19eb6dd45d
+ sha1sums = 81547a110d9e28897e41f2f8accabb7721dbcc19
+ sha1sums = 14cb27e5e45dacf8e59cfb498235036716393014
sha1sums = a893c32f2a3fff8b279025ec60f0c3d88143dc1e
sha1sums = 9270b5e33d4508a959688a10c20dec3732763937
sha1sums = 34a33b47a8b667f9dc810737c0f598660b962d4c
- sha1sums = 2e69ac6c8e3674faf7e5d1739f9d772d50332fc0
+ sha1sums = cf79c015d16f839ef8014cc45944613972552dc9
sha1sums = 0022423564ed30dfe91bb3faa7f0c03ddcf4f25f
sha1sums = fbd6ee512b6486320d41a007b9670dcf5a3430b6
sha1sums = 4d11331aeff1c1ec3de3759710acc060769ef274
@@ -48,11 +47,10 @@ pkgbase = makepkg-optimize
sha1sums = eef21d80145bf64133206beba26fd7fab5a8f5bc
sha1sums = 2e2cd8c680a86518652543fda9092bf2ab594660
sha1sums = 981eab856abb43c5e093620cdf4d8bfa2d690805
- sha1sums = 540ce964ef6f3bdda1d7b7fd6297866b1ee895b1
+ sha1sums = bce04a9513419bc70ae9b61bb70aa40528334eca
sha1sums = efb3ed7d7d5516259709149d7bcd6ec208c07593
sha1sums = 1fc8035e64b739e20c70fbb4eaa5cb7aa1c63c90
sha1sums = 5d0cde13b50641371e4ec4d813d6b2dfae493889
- sha1sums = 67801619b39ea4542829a4b715034a9f7ac7cf2c
+ sha1sums = 5be1195c15c33c477910bca83b29ade3b10a2b10
pkgname = makepkg-optimize
-
diff --git a/PKGBUILD b/PKGBUILD
index 00c0618cc783..3ff9ae966c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Que Quotion ( quequotion@bugmenot.com )
-# Contributor: bartus ( aur\at\bartus.33mail.com )
+
pkgname=makepkg-optimize
-pkgver=18
-pkgrel=3
+pkgver=21
+pkgrel=1
pkgdesc='Supplemental build and packaging optimizations for makepkg'
arch=('any')
license=('GPL')
@@ -12,9 +12,10 @@ depends=('pacman')
optdepends=("upx: Compress executables"
"optipng: Optimize PNG files"
"svgo: Optimize SVG files"
- "openmp: Parallelize loops")
+ "openmp: Parallelize loops"
+ "polly: Polyhedral model optimization for clang")
backup=(etc/makepkg-optimize.conf)
-_buildenv=({pgo,ZZ-lto,graphite,rice}.sh.in)
+_buildenv=({pgo,graphite,rice}.sh.in)
_executable=({upx,optipng,svgo}-exec.sh.in)
_tidy=({upx,optipng,svgo}.sh.in)
_conf=({{c,cxx,make,ld,debug-make,cmake-}flags,{buildenv,destdirs,pkgopts{,-param}}_ext,compress-param_max}.conf)
@@ -22,14 +23,13 @@ source=(${_buildenv[@]}
${_executable[@]}
${_tidy[@]}
${_conf[@]})
-sha1sums=('2b746b2d8bf57691f1b25afce96a2752f6eee7e5'
- '61c765080f3d41dbae15be9212667f9e6364550b'
- 'd7a3801037333c582dba976db27cf8896bc1b401'
- 'c99d9cb49dd31924a1cb298bcfe142cef31a9fd3'
+sha1sums=('4c5f0be71638a6ec2f18c01675d99f19eb6dd45d'
+ '81547a110d9e28897e41f2f8accabb7721dbcc19'
+ '14cb27e5e45dacf8e59cfb498235036716393014'
'a893c32f2a3fff8b279025ec60f0c3d88143dc1e'
'9270b5e33d4508a959688a10c20dec3732763937'
'34a33b47a8b667f9dc810737c0f598660b962d4c'
- '2e69ac6c8e3674faf7e5d1739f9d772d50332fc0'
+ 'cf79c015d16f839ef8014cc45944613972552dc9'
'0022423564ed30dfe91bb3faa7f0c03ddcf4f25f'
'fbd6ee512b6486320d41a007b9670dcf5a3430b6'
'4d11331aeff1c1ec3de3759710acc060769ef274'
@@ -38,11 +38,11 @@ sha1sums=('2b746b2d8bf57691f1b25afce96a2752f6eee7e5'
'eef21d80145bf64133206beba26fd7fab5a8f5bc'
'2e2cd8c680a86518652543fda9092bf2ab594660'
'981eab856abb43c5e093620cdf4d8bfa2d690805'
- '540ce964ef6f3bdda1d7b7fd6297866b1ee895b1'
+ 'bce04a9513419bc70ae9b61bb70aa40528334eca'
'efb3ed7d7d5516259709149d7bcd6ec208c07593'
'1fc8035e64b739e20c70fbb4eaa5cb7aa1c63c90'
'5d0cde13b50641371e4ec4d813d6b2dfae493889'
- '67801619b39ea4542829a4b715034a9f7ac7cf2c')
+ '5be1195c15c33c477910bca83b29ade3b10a2b10')
prepare() {
# Use the current makepkg config as a base
diff --git a/buildenv_ext.conf b/buildenv_ext.conf
index caa8c939e2cb..e21aff679186 100644
--- a/buildenv_ext.conf
+++ b/buildenv_ext.conf
@@ -1,5 +1,3 @@
-#-- lto{,-clang}: Use monolithic link-time optimization (use "lto-clang" for clang/llvm)
-#-- lto-thin{,-clang}: Use partitioned link-time optimization (use "lto-thin-clang" for clang/llvm)
#-- pgo: Generate or utilize profile guided optimization (requires two build and install cycles)
#-- {graphite,polly}: Use polyhedral model optimization (use "polly" for clang/llvm)
#-- rice{,-clang}: Use extreme and unsafe optimization (use "rice-clang" for clang/llvm)
diff --git a/compress-param_max.conf b/compress-param_max.conf
index ea5cbe121586..2eb2d3724e24 100644
--- a/compress-param_max.conf
+++ b/compress-param_max.conf
@@ -1,7 +1,7 @@
#COMPRESSGZ=(gzip -c -f -n --best)
#COMPRESSBZ2=(bzip2 -c -f --best)
-#COMPRESSXZ=(xz -T "$(getconf _NPROCESSORS_ONLN)" -c -z --best -)
-#COMPRESSZST=(zstd -c -z -q --ultra -T0 -22 -)
+#COMPRESSXZ=(xz -T0 -c -z --best -)
+#COMPRESSZST=(zstdmt -c -z -q --ultra -22 -)
#COMPRESSLRZ=(lrzip -9 -q)
#COMPRESSLZO=(lzop -q --best)
#COMPRESSZ=(compress -c -f)
diff --git a/graphite.sh.in b/graphite.sh.in
index 37b729f625df..88f30e39a6c6 100644
--- a/graphite.sh.in
+++ b/graphite.sh.in
@@ -16,6 +16,8 @@ buildenv_functions+=('buildenv_graphite')
buildenv_graphite() {
if check_buildoption "graphite" "y" || check_buildoption "polly" "y"; then
graphiteflags=" -lgomp -mllvm -polly -mllvm -polly-num-threads=$(getconf _NPROCESSORS_ONLN) -mllvm -polly-parallel"
+ check_buildoption "polly" "y" && \
+ graphiteflags+=" -Xclang -load -Xclang LLVMPolly.so"
check_buildoption "graphite" "y" && \
graphiteflags=" -fgraphite-identity -floop-interchange -floop-nest-optimize -floop-parallelize-all -ftree-loop-distribution -ftree-parallelize-loops=$(getconf _NPROCESSORS_ONLN) -ftree-vectorize"
diff --git a/pgo.sh.in b/pgo.sh.in
index 4fb016c68edd..f2686c89fc53 100644
--- a/pgo.sh.in
+++ b/pgo.sh.in
@@ -36,6 +36,7 @@ buildenv_pgo() {
[[ -d $PROFDEST/$pkgbase.used ]] && rm -rf $PROFDEST/$pkgbase.used
mv $PROFDEST/$pkgbase.{gen,used}
pgoflags=" -fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
+ pgoldflags=" -lgcov"
msg2 "Profile data will be applied."
fi
diff --git a/rice.sh.in b/rice.sh.in
index 9f253488786e..5946791b1394 100644
--- a/rice.sh.in
+++ b/rice.sh.in
@@ -15,9 +15,9 @@ buildenv_functions+=('buildenv_rice')
buildenv_rice() {
if check_buildoption "rice" "y" || check_buildoption "rice-clang" "y"; then
- riceflags=" -Ofast -fdata-sections -ffloat-store -fgcse-las -fgcse-sm -fmodulo-sched -fmodulo-sched-allow-regmoves -funsafe-math-optimizations -fno-threadsafe-statics -fomit-frame-pointer -fopenmp -fPIC -freg-struct-return -fshort-wchar -fvariable-expansion-in-unroller -Wno-sizeof-pointer-memaccess -pthread" #
+ riceflags=" -Ofast -fdata-sections -ffloat-store -fgcse-las -fgcse-sm -fmodulo-sched -fmodulo-sched-allow-regmoves -funsafe-math-optimizations -fno-threadsafe-statics -fomit-frame-pointer -fopenmp -fPIC -fshort-wchar -fvariable-expansion-in-unroller -Wno-sizeof-pointer-memaccess -pthread" #
check_buildoption "rice" "y" && \
- riceflags+=" -fbranch-target-load-optimize2 -fcx-fortran-rules -fipa-pta -fno-enforce-eh-specs -fnothrow-opt -fno-var-tracking-assignments -freschedule-modulo-scheduled-loops -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns=0 -fsched2-use-superblocks -fselective-scheduling -fselective-scheduling2 -fsel-sched-pipelining -fsel-sched-pipelining-outer-loops -ftree-lrs -maccumulate-outgoing-args" # -fmerge-all-constants
+ riceflags+=" -fbranch-target-load-optimize2 -fcx-fortran-rules -fipa-pta -fno-enforce-eh-specs -fnothrow-opt -fno-var-tracking-assignments -freg-struct-return -freschedule-modulo-scheduled-loops -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns=0 -fsched2-use-superblocks -fselective-scheduling -fselective-scheduling2 -fsel-sched-pipelining -fsel-sched-pipelining-outer-loops -ftree-lrs -maccumulate-outgoing-args" # -fmerge-all-constants
riceldflags=" -lpthread -lgomp" # -shared
CFLAGS+="$riceflags"
diff --git a/upx.sh.in b/upx.sh.in
index 43c33d37fc60..0de332c8049c 100644
--- a/upx.sh.in
+++ b/upx.sh.in
@@ -20,16 +20,17 @@ tidy_upx() {
local binary
find . -type f -perm -u+w 2>/dev/null | while read -r binary ; do
[ $(jobs -p|wc -l) -gt $(getconf _NPROCESSORS_ONLN) ] && wait -n
- mime=$(file --brief --mime-type "$binary")
- case "$mime" in
- application/x-executable | application/x-dosexec )
- { upx "${UPXFLAGS[@]}" "$binary" &>/dev/null ||
+ case "$(file -S --brief --mime-type "$binary")" in
+ application/x-executable | application/x-dosexec | \
+ application/x-pie-executable | application/x-sharedlib )
+ { upx "${UPXFLAGS[@]}" "$binary" &>/dev/null &&
+ info "$(gettext "Compressed binary : %s")" "${binary/$pkgdir\//}" ||
warning "$(gettext "Could not compress binary : %s")" "${binary/$pkgdir\//}"; } &
;;
- application* )
- warning "$(gettext "Not compressing %s, $(file --brief --mime-type "$binary")")" \
- "${binary/$pkgdir\//}"
- ;;
+ #application* )
+ # warning "$(gettext "Not compressing %s, $(file --brief --mime-type "$binary")")" \
+ # "${binary/$pkgdir\//}"
+ #;;
esac
done
wait