summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--pgo.sh.in1
-rw-r--r--upx.sh.in17
4 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 006182e7978f..4f16ffd8948c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = makepkg-optimize
pkgdesc = Supplemental build and packaging optimizations for makepkg
pkgver = 18
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.archlinux.org/index.php/Makepkg-optimize
arch = any
license = GPL
@@ -32,14 +32,14 @@ pkgbase = makepkg-optimize
source = pkgopts_ext.conf
source = pkgopts-param_ext.conf
source = compress-param_max.conf
- sha1sums = 2b746b2d8bf57691f1b25afce96a2752f6eee7e5
+ sha1sums = 4c5f0be71638a6ec2f18c01675d99f19eb6dd45d
sha1sums = 61c765080f3d41dbae15be9212667f9e6364550b
sha1sums = d7a3801037333c582dba976db27cf8896bc1b401
sha1sums = c99d9cb49dd31924a1cb298bcfe142cef31a9fd3
sha1sums = a893c32f2a3fff8b279025ec60f0c3d88143dc1e
sha1sums = 9270b5e33d4508a959688a10c20dec3732763937
sha1sums = 34a33b47a8b667f9dc810737c0f598660b962d4c
- sha1sums = 2e69ac6c8e3674faf7e5d1739f9d772d50332fc0
+ sha1sums = cf79c015d16f839ef8014cc45944613972552dc9
sha1sums = 0022423564ed30dfe91bb3faa7f0c03ddcf4f25f
sha1sums = fbd6ee512b6486320d41a007b9670dcf5a3430b6
sha1sums = 4d11331aeff1c1ec3de3759710acc060769ef274
diff --git a/PKGBUILD b/PKGBUILD
index 00c0618cc783..08356b188a09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=makepkg-optimize
pkgver=18
-pkgrel=3
+pkgrel=4
pkgdesc='Supplemental build and packaging optimizations for makepkg'
arch=('any')
license=('GPL')
@@ -22,14 +22,14 @@ source=(${_buildenv[@]}
${_executable[@]}
${_tidy[@]}
${_conf[@]})
-sha1sums=('2b746b2d8bf57691f1b25afce96a2752f6eee7e5'
+sha1sums=('4c5f0be71638a6ec2f18c01675d99f19eb6dd45d'
'61c765080f3d41dbae15be9212667f9e6364550b'
'd7a3801037333c582dba976db27cf8896bc1b401'
'c99d9cb49dd31924a1cb298bcfe142cef31a9fd3'
'a893c32f2a3fff8b279025ec60f0c3d88143dc1e'
'9270b5e33d4508a959688a10c20dec3732763937'
'34a33b47a8b667f9dc810737c0f598660b962d4c'
- '2e69ac6c8e3674faf7e5d1739f9d772d50332fc0'
+ 'cf79c015d16f839ef8014cc45944613972552dc9'
'0022423564ed30dfe91bb3faa7f0c03ddcf4f25f'
'fbd6ee512b6486320d41a007b9670dcf5a3430b6'
'4d11331aeff1c1ec3de3759710acc060769ef274'
diff --git a/pgo.sh.in b/pgo.sh.in
index 4fb016c68edd..f2686c89fc53 100644
--- a/pgo.sh.in
+++ b/pgo.sh.in
@@ -36,6 +36,7 @@ buildenv_pgo() {
[[ -d $PROFDEST/$pkgbase.used ]] && rm -rf $PROFDEST/$pkgbase.used
mv $PROFDEST/$pkgbase.{gen,used}
pgoflags=" -fprofile-correction -fprofile-use -fprofile-dir=$PROFDEST/$pkgbase.used"
+ pgoldflags=" -lgcov"
msg2 "Profile data will be applied."
fi
diff --git a/upx.sh.in b/upx.sh.in
index 43c33d37fc60..0de332c8049c 100644
--- a/upx.sh.in
+++ b/upx.sh.in
@@ -20,16 +20,17 @@ tidy_upx() {
local binary
find . -type f -perm -u+w 2>/dev/null | while read -r binary ; do
[ $(jobs -p|wc -l) -gt $(getconf _NPROCESSORS_ONLN) ] && wait -n
- mime=$(file --brief --mime-type "$binary")
- case "$mime" in
- application/x-executable | application/x-dosexec )
- { upx "${UPXFLAGS[@]}" "$binary" &>/dev/null ||
+ case "$(file -S --brief --mime-type "$binary")" in
+ application/x-executable | application/x-dosexec | \
+ application/x-pie-executable | application/x-sharedlib )
+ { upx "${UPXFLAGS[@]}" "$binary" &>/dev/null &&
+ info "$(gettext "Compressed binary : %s")" "${binary/$pkgdir\//}" ||
warning "$(gettext "Could not compress binary : %s")" "${binary/$pkgdir\//}"; } &
;;
- application* )
- warning "$(gettext "Not compressing %s, $(file --brief --mime-type "$binary")")" \
- "${binary/$pkgdir\//}"
- ;;
+ #application* )
+ # warning "$(gettext "Not compressing %s, $(file --brief --mime-type "$binary")")" \
+ # "${binary/$pkgdir\//}"
+ #;;
esac
done
wait